I have a Samsung Galaxy S2. My GPS doesn't work. It just says "Waiting for location" the whole time. At first when I bought the phone, I think it worked correctly, but now it doesn't. I tried: androidng.com/fix-galaxy-s-gps and similar stuff, nothing helped. How can I enabled the GPS function?

P.S. I installed a few apps for battery savings, I disabled them now, maybe it was a cause? But it still doesn't work. I could reset everything probably, but then my apps would be deleted, right?

3 Answers 3


I can't speak to the instructions you linked to, but @Ryan Conrad is correct in saying Galaxy S and Galaxy S II devices shouldn't be treated the same.

Whenever I've had GPS trouble the GPS Status & Toolbox app has helped me. In their tools menu you can use the reset or download A-GPS data options - those steps seems to reset my GPS when it hangs.


You may have done more harm then good running that "fix". The fix is for the Samsung Galaxy S line of phones, not the Galaxy S II. The Galaxy S has a horrid GPS in it. It takes forever to get a lock, or it never even gets a lock. There have been a bunch of "fixes" that were supposed to fix it, but none ever really fixed anything for me on my Galaxy S. These fixes usually do things like change the GPS server and the timeout or other things. But as I said, these are for the Galaxy S, not the Galaxy S II.

The GPS, AFAIK, is better in the S2. But GPS in general can be "flaky" depending on your location and if there is heavy overcast. If the device cannot get a fix on the Positioning Satellite it will sit there and "Wait for location".

You may want to do a factory reset of the device, that should put the settings back in the original state. Unless you are rooted and modified system files with the "fixes". If that is the case, you may want to find the "stock rom" and restore the device to its "true original state".


I tried the S2 GPS function today on my walk and at first it worked like a charm. Half way through my walk I could not get a fix anymore. At first I thought that it was due to my battery getting low but getting back to a full charge did not fix the problem. I tried a number of thing without success. I finally opted to power off, remove the battery and power back on and everything was back to normal. I do not know if it was pure chance but I would be interested to know if other users experienced the same thing.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .