1

I created a docx file in LibreOffice on my computer running Debian 9.1 with KDE and copied it to my Android phone. On the phone I try to open the file with the LibreOffice app. However I can't edit the file and just read the document as it's read-only - I get:

This file is read-only, saving is disabled.

I already tried a couple of other formats and doing File->Save a Copy on my computer.
How can I get it to be editable?

5
  • Try Open Document Reader which opens and permits modifications of all files in ODF ( format used by Libre office and Open office
    – beeshyams
    Aug 24, 2017 at 15:27
  • May I ask why do you insist on using DOCX (proprietary) as an extension instead of using a native and open-source extension in LibreOffice, such as ODF? If ideology is not an issue, you can consider MS Office Mobile to edit docx effortlessly. It also can edit (per my experience) ODF files.
    – Firelord
    Aug 24, 2017 at 16:04
  • I don't insist on using docx (note that I also tried the Office Open XML Text .docx). Actually I would prefer using ODT. But with an .odt file I get a blank screen that says "All apps associated with this action have been turned off, blocked or not installed" when I try to open it. Maybe that's worth a separate question or an edit to the question. (And I don't want to use anything else except LibreOffice or, if necessary, OpenOffice.)
    – mYnDstrEAm
    Aug 24, 2017 at 17:14
  • Is it stored in a location that LibreOffice has permission to write to? I don't know if the LibreOffice app has the ability to create new files, but if it does then it may be worth testing to see if it can save a new file into the same directory that you've got your exiting one in. Aug 24, 2017 at 17:38
  • I tried my internal storage and my SD card. I get the same error for both locations. Not sure if there are some specific subfolders one could try in addition. I also tried the app OpenDocumentReader which didn't even show up in the list of apps to open the file with nor does its browsing work. What is going on here?
    – mYnDstrEAm
    Aug 24, 2017 at 21:36

1 Answer 1

-1

In your computer open terminal and cd to the directory where the file is located, then type sudo chmod 777 PATH_TO_FILE, then send it to your device.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .