0

I own a Huawei MediaPad M2 10.0 (M2-01AL). It was rooted since long.

I wanted to try to install Magisk, so I did it from Magisk Manager. I don't exactly remember what I exactly did, but eventually I screw up the tablet entirely that it entered a boot loop at the Huawei logo.

I just want to reflash it from stock, or something that boots

I have tried several fastboot flashing, but eventually got my hands, thanks to XDA, on what look like official stock firmwares by Huawei. File names:

These archives contain the magic update.app to be put into SD card and then boot the tablet with all keys pressed.

The firmware flashes the entire contents of the archive into the ROM. However such a flashing stops at around 90% with a generic failure message and request to reboot.

The tablet won't boot.

This is entirely a software problem with the device.

Also tried extracting the .img from the .app with Huawei Extractor and flashing system via fastboot, no result. Phone is still unlocked and FRP is unlocked, as the bootloader reports. I can flash recovery successfully, but I haven't yet found an English TWRP, only luck Chinese and Russian.

Question is: how do I restore this tablet to at least a bootable state? I would like to try this alone before going to a repair shop in my city, there are plenties of it.

Updates

I have successfully installed TWRP in a language I understand. I can see that the system partition is damaged because TWRP, on reboot, says that no OS is installed. This is a first step. I also reflashed stock boot just to make sure, because I found that in order to uninstall Magisk one has to flash the backup Magisk makes. Unfortunately I had no time to fetch that backup, I was too lazy. Anyway I extracted system from the update.app and flashed it via fastboot. No result, the tablet is still in boot loop

  • Of course I will edit my question to provide any possible clarification upon comments – usr-local-ΕΨΗΕΛΩΝ Aug 24 '17 at 19:52
  • I'm voting to close this question as off-topic because I have sold the device as scrap and answer is no longer required – usr-local-ΕΨΗΕΛΩΝ Jun 14 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.