0

I was trying to follow the instructions at http://www.teamandroid.com/2016/01/20/install-android-601-omnirom-nexus-7-2012-marshmallow-custom-rom/2/, which walk through downloading omni-6.0.1-20160115-grouper-HOMEMADE.zip, copying it to the root of the sdcard storage, and using clockwork recovery module to wipe the device and install it. I ran into a problem when trying to install the ZIP file downloaded from https://www.androidfilehost.com/?fid=24369303960685419 (which I was able to successfully select). An error is reported:

ApplyParsedPerms: removexattr of system/bin/backuptool.sh to 0 failed: Operation not supported on transport enpoint

Subsequently a Status 7 failure causes the installation to abort. The failure happened quite early (fortunately?) so I am still able to reboot and use the freshly wiped device, but I'd like to install this ROM because 2012 model Nexus 7s are notoriously unusable on Android 5.1.1, which is the latest OS formally available to them.

How do I get past this? The page I was following was supposedly specifically for the 2012 model of Nexus 7, which I have, so I thought this should have worked.

Update: Looking at the updater-script, I suspect this is the line that's failing, but I don't know enough about the design of this package or alternate ROMs to understand whether the problem is in the script or somewhere else:

set_metadata("/system/bin/backuptool.sh", "uid", 0, "gid", 0, "mode", 0755, "capabilities", 0x0);
  • 1
    You should use TWRP instead of cwm. Which 2012 nexus 7 is it? The Wi-Fi or the GSM (3g) version? The status 7 generally is a wrong device error. – Bo Lawson Aug 27 '17 at 23:03
  • @BoLawson I have the W-Fi model. – BlueMonkMN Aug 27 '17 at 23:15
  • @BoLawson I figured out how to try TWRP, and it seemed to work better. Strange the method in the instructions didn't work. – BlueMonkMN Aug 27 '17 at 23:30
  • The instructions are super old CWM is no longer in development. So, did you get it working with twrp? Or are you still getting status 7? Also here is the download from Omni's site. Probably better than third party. dl.omnirom.org/grouper – Bo Lawson Aug 28 '17 at 0:10
  • @BoLawson I got it working, but I can't get GApps installed because I only have 200 MB free on the system partition. I can't decide whether I should try stepping down again from micro to nano or if there's garbage that needs to be cleaned up on the system partition. Total system space is 655104 KB; Used is 451348 KB. – BlueMonkMN Aug 28 '17 at 0:12
0

Using TWRP 3.0.2 (with WugFresh Nexus Root Toolkit 2.1.9) instead of Clockwork worked.

  • Is there a particular version you used? – Firelord Aug 29 '17 at 12:56
  • 1
    The version I used came with Wug's Nexus Root Toolkit, which I believe was at 2.1.9, or was downloaded as part of the installation process of that toolkit. I'll have to look it up when I get home to be more specific than that. I did have to download updated versions of a couple things while installing that so the version of the toolkit itself may be irrelevant. – BlueMonkMN Aug 29 '17 at 13:08
  • Thanks. If you look it up again, please edit your post to incorporate your findings. That would be helpful. – Firelord Aug 29 '17 at 13:14
  • @Firelord Version information added. – BlueMonkMN Aug 30 '17 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.