0

Xposed framework (ver 85) on my device Moto X Play has options greyed out as shown - only soft reboot and reboot are not greyed out

enter image description here

This happened over last three days when I was trying out some modules , so can't pinpoint which caused it

  1. Xposed framework and modules are working fine

  2. Restoring Framework from earlier TiBu backup which didn't have this problem did not help - it remains greyed out

  3. Clearing cache and data of installer also didn't help

I've come across cases on Internet where this is associated with framework not working properly or wrong framework installed, which clearly isn't the case here ( it was installed many months ago )

So my question is, should I be concerned about it ?

My feeling is that it's not causing any problems (Point 1) , so it's pointless going through uninstalling and installing it. But just to be sure, wanted a second opinion on this, maybe with reasons why this happened

  • Does the Installer have root permissions? – Death Mask Salesman Aug 29 '17 at 11:28
  • @DeathMaskSalesman: checked. Yes, it has – beeshyams Aug 29 '17 at 11:30
  • 1
    I've no answer this time, as I'm using Nougat. What I can say, is that I once stumbled on the same behavior. – Death Mask Salesman Aug 29 '17 at 11:31
  • Could you share (| link to) your Xposed Installer APK? – Death Mask Salesman Aug 29 '17 at 11:35
  • 1
    I also had v3.0 alpha 4 release downloaded from rovo89's official thread and so as the framework. This greyed out issue persisted but it did not affect anything in my Android 6.0.1. I now use v3.1.1 (unofficial; material design) installer. – Firelord Aug 29 '17 at 12:53
1

I used Xposed some time ago and as far I can remember those buttons are grayed out because on marshmallow (possibly lollipop) you must flash framework files via .zip file. Maybe I'm wrong and forgot something. Are you sure it happened recently, that it wasn't there all the time? However I don't think you should be concerned because Xposed and it's modules work fine (right?). It says "Xposed framework 85 is active"

  • Thanks. Very sure it happened recently. As I said, it may not make a difference but thought somebody may know the reason – beeshyams Aug 29 '17 at 15:36
0

When Xposed Installer (de.robv.android.xposed.installer) can't connect to its server, the install buttons will grey out. Check your internet connection.

  • I don't think that's the case. My internet is working fine. I have no firewalls to filter either. Besides, after seeing your answer, was able to update one of the modules using the installer – beeshyams Aug 29 '17 at 12:04
  • @beeshyams Remember a Server Fault can also be the cause. I should emphasize your connection to the Xposed server. – iBug Aug 29 '17 at 12:10
  • 1
    @beeshyams Modules are in repo.xposed.info, which does not seem to be the place where flashable zips lies. – iBug Aug 29 '17 at 12:15
  • 1
    @beeshyams Try pinging 70.34.227.107. – Death Mask Salesman Aug 29 '17 at 14:17
  • 1
    @DeathMaskSalesman: since I don't have access to my computer, used this app to ping and it passed. No problems. Thanks for providing domain – beeshyams Aug 29 '17 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.