2

I am trying to get to the point where I can put in the Bootloader code that I have. But fastboot keeps waiting for the device in CMD and it never shows up, no matter how many times I do volume up or down and USB plugged in.

Debug active, in Mass storage, Sony ADB shows up in drivers with no errors. Any help would be appreciated.

2
  • Please include your device info in the question.
    – Grimoire
    Commented Aug 29, 2017 at 16:00
  • 1
    Well, if ADB shows the device fine, fastboot obviously cannot see it (and vice versa). Fastboot can only access the device if booted into the bootloader ;) For more details, you might wish to consult our fastboot tag-wiki.
    – Izzy
    Commented Aug 29, 2017 at 16:32

3 Answers 3

3

First, make sure you are in fastboot mode. The easy way would be connecting your phone to your PC via a USB cable with USB debugging enabled.

Then, simply open CMD from the directory where you installed ADB (or just open CMD if it's installed globally).

Then make sure ADB detected the phone via adb devices. If your device shows up, just type adb reboot bootloader and the phone will reboot to fastboot mode.

After that, open CMD and use fastboot devices. If you get your device, you can proceed with unlock process, but if it doesn't return anything or sits on "waiting for device", then the first thing you should do is to try to plug USB into another USB port (for some reason fastboot is a massive pain in the ass when you try to use it on USB 3.0 port, so if you have USB 2.0 port try to plug USB into it, this is trouble only on Windows). If you don't have USB 2.0 port, then you should consider using Linux live USB to unlock the bootloader. However, if you plug the phone into USB 2.0 port and still is not detected, then you should try some other USB drivers, from the manufacturer's site or universal ADB drivers. Here is the link for various phones, so check it out.

Once, I managed to solve this by manually changing drivers (it's possible on Windows 7 and probably later, I can't tell the exact process since I don't have a PC currently). I chose something like "LG USB fastboot" because my phone is LG.

0
0

I also get that "waiting for devices" on Windows 10. I try to get to fastboot manually by pressing up + volume. After I get fastboot mode, I connect with a USB cable. Then when I check the device manager, I see a yellow exclamation sign.

I search for the correct driver (Google USB driver is not enough to fix this), update the driver, and ADB finally sees my devices in fastboot mode.

0

Had the same problem with Xperia XZ3. Tried everything... lost hope.. then switched to USB 2.0 -> device manager saw the phone as an Android device (WHILE PHONE OFF, which was the main issue as it turns out) -> installed manually Google USB driver from here -> rebooted laptop and phone and then the regular procedure with adb worked (fastboot devices list showed my phone while booted in bootloader). Following that, I used the command fastboot -s <usb id from fastboot devices list> oem unlock 0x<unlock bootloader code>.

Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .