0

I am tring to connect via adb to tablet that is stuck on welcome screen and doesn't want to boot. If i run 'adb devices' i get this:

E:\minimal_adb_fastboot_1.4.1_portable>adb.exe devices
List of devices attached
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
0123456789ABCDEF        unauthorized

And if i try to connect i get this:

E:\minimal_adb_fastboot_1.4.1_portable>adb.exe connect 192.168.100.13
unable to connect to 192.168.100.13:5555: cannot connect to 192.168.100.13:5555: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)

Is it possible to connect to the device if the operating system is not fully loaded?

  • adb connect assumes the device is accessible via TCP. Output of adb devices rather suggests it's connected via USB. Further, the string unauthorized usually means on first access you'll have to confirm (authorize) the connection on the device; not sure if the corresponding screen would pop up in your situation. Have you tried a simple adb shell ls? – Izzy Aug 30 '17 at 14:43
  • The tablet screen doesn't show authorization dialog. And if i run 'adb shell ls' i get: E:\minimal_adb_fastboot_1.4.1_portable>adb.exe shell ls error: device unauthorized. This adb server's $ADB_VENDOR_KEYS is not set Try 'adb kill-server' if that seems wrong. Otherwise check for a confirmation dialog on your device. – user1800997 Aug 30 '17 at 14:59
  • That's what I was afraid of. The confirmation dialog usually pops up as soon as you connect the cable. Without confirmation, no access. That leaves the option mentioned in Firelord's answer: if you can find a custom recovery for your tablet that supports ADB (rare cases, but checking cannot hurt – neither does mentioning your device in your question as someone might know), you could access it that way. Until then: booting into the stock ("3e") recovery and wiping cache might help as well to get it booting up fully. – Izzy Aug 30 '17 at 15:17
0

It is possible to connect to the device through adb when it is stuck on welcome screen or even when it is showing boot animation. The problem in your case is that your device has not authorized the connection. Under normal circumstances, when you connect through adb a dialog is shown on the device for user's confirmation to proceed. Until the user agrees, you can't do anything good with adb. And since you're stuck on welcome screen, I see no way to agree to the dialog.

That been said, if you can somehow manage to flash a compatible custom recovery you can pretty much salvage all of your data. You might also be able to solve this adb unauthorized issue.

  • I don't have custom recovery, only stock recovery and if i boot the tablet in recovery mode the adb shell doesn't recognize it. – user1800997 Aug 30 '17 at 15:01
  • Yeah, the stock recovery is no good for adb that's why I mentioned about custom recovery only. – Firelord Aug 30 '17 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.