-1

Ok so you might be thinking how I did it. Long story short My anti-virus (Webroot mobile) flagged it as a Trojan/Rootkit, and decided it would be a great idea to uninstall it without my concern. Now my root access is bugged and some root apps are bugging out. Any help will be appreciated. BTW I tried installing KingRoot again with the hopes that it will detect something and install itself back on the system.

Phone specs: OS: Android 4.4.4

Brand: Lenovo

Model: A6000+

I'm thinking about factory reset, is that going to help?

  • You cannot install kingroot apk with an active Internet connection. It will be blocked. – Alain Giresse Sep 8 '17 at 10:51
  • "I tried installing KingRoot again" - what happened when you tried? – Dan Hulme Sep 8 '17 at 15:56
  • Well, it just says App is not installed or something like that. You know this screen you see sometimes when installing external apks. – MarinB Sep 8 '17 at 18:29
0

If a custom recovery is installed you may flash SuperSU as it is far more reliable (in my opinion) than the KingoRoot root manager. In SuperSu root manager you can install backup script which may prevent the same situation from happening.

  • Thank you I will research it and tell you if I can succeed. – MarinB Sep 3 '17 at 7:39
  • BTW when I tried to install KingRoot.apk again, it says App not installed. If you could help me with that, I might be able to fix everything. – MarinB Sep 3 '17 at 7:42
  • You can try installing the SuperSu app from the play store. – user6470140 Sep 3 '17 at 9:16
  • I have tried but it says SU binary occupied. I have researched on the error but nothing seems to fix it – MarinB Sep 3 '17 at 9:27
0

It happened to me once, but KingRoot should be a system application. What helped me was a factory reset, but that is only an option you can try getting Kingoroot and try to use it and uninstall anything left from KingRoot (use only a "built-in uninstaller" don't try to remove su-binary stuff), then uninstall Kingoroot and unroot then you can go back again to KingRoot. Although, you want to do a backup as you have the ability to.

  • 1
    When I try to install Kingroot again it fails – MarinB Sep 3 '17 at 18:36
  • Are you sure that you completely removed KingRoot? Use something like System app uninstaller or App2SD's uninstaller which is preferred and completely remove KingRoot then use Broken App Cleaner and reboot, then try to install again, after all you have the backup and factory reset option. @MarinB – SuicidalMK Sep 4 '17 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.