0

I wanted to install Global Developer ROM for my Redmi 3s Prime which I downloaded from their website. So I started with installing TWRP custom recovery and completed successfully. After this I installed my developer ROM and after success TWRP tool asked me whether to root the phone or not, to which I said YES.

After this blank screen appeared for very long time and nothing happened. So, I long pressed the power button and now my phone is not booting up at all.

I tried the following things but none of them are working.

  1. Fastboot mode by pressing VOLUME DOWN + POWER buttons.
  2. Recovery mode by pressing VOLUME UP + POWER Buttons
  3. Also tried by pressing all three buttons.

I also ran these commands adb devices and fastboot devices, cannot see my device.

And even the battery charging indicator is also not showing up.

Is there any tool or something which can help me to fix this problem?

Any help is appreciated.

  • Are you sure you installed version that matches your exact model all phones have their code names (because phones have different variants in some countries)? One more thing did you downloaded stock firmware or custom ROM made by some developer? To me it sounds like hard bricked device. – Једноруки Крстивоје Sep 3 '17 at 1:54
  • @ЈеднорукиКрстивоје Yes, I've downloaded the correct ROM. On Xiaomi official website there are two ROMs, stable ROM and developer ROM (Both are official). I've used developer ROM. – FAЯAƸ Sep 3 '17 at 8:56
  • @ЈеднорукиКрстивоје And I can hear the USB plugin sound when I connect my phone to my laptop. When I try to go into recovery mode while my phone is connected to the laptop, this sound keeps on playing in a loop. – FAЯAƸ Sep 3 '17 at 8:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.