0

I have TCL Alcatel Pixi 4 (5) 5010D phone that i bought and decided to root it. I was kinda new to this kind of rooting (a bit complex) because i used kingroot before and it worked just fine till i got this phone and no app for rooting helped me which lead me to rooting using my computer.

I've searched on google and found one thread on XDA by kirito9, showing his tutorial on rooting Alcatel pixi phones and i've found mine there. Multiple choices occured and i couldn't decide which one is easier for me. So i went on to try phh's superuser method. Everything went fine, i've got TWRP installed on my phone and flashed phh's superuser onto my phone, rebooted and... well it booted fine. Installed the required superuser and Titanium Backup. Superuser worked fine and so did Titanium Backup.

Later i decided to uninstall some system apps that i didn't need and were wasting space so i downloaded system app remover and allowed root access.. as soon as i tried to uninstall the app, my device rebooted. I thought that was a normal process but i saw that the app did not uninstall. Tried again, same thing. After doing some research, found out that i don't have access to rewriting /system and files in it at all. I tried downloading an app again to make /system rewritable, but no access. Then tried it through ADB but didn't work as well.

So not sure but i think that's half root which i don't want, i wanted full root but i didn't get it. Now i wish to remove this phh's superuser and trying to get root another way if i can without bricking my device and of course, making /system rewritable so i can uninstall useless apps. Can't even install busybox because of this. Would appreciate help on both uninstalling phh's superuser and getting another method of safely rooting my phone.

  • My speculation on why: on newer Android versions /system is often protected from modifications using dm-verity, which can reboot the OS as soon as a corrupted block is discovered. dm-verity is turned on in the kernel and there's no universal way of turning it off unless you use another (custom) kernel, which many devices just don't have. You'll probably have to resort to pm disable or pm hide. – Andy Yan Sep 3 '17 at 1:00
  • Also, deleting apps from /system does not save you space. – Andy Yan Sep 3 '17 at 1:01
  • Not trying to save space, they're just annoying as i dont need them. So i cant do anything about this? I wish to install busybox as well, not just uninstalling system apps but its not allowing me due to /system not being rewritable. I wish i could install Viper4android but still makes changes to /system files when it's installing it's own drivers but even after reboot no changes are made. – Wolf Sep 3 '17 at 1:08
  • I did say that you can use pm disable or pm hide. Other /system modifications would have to be "systemless", i.e. applied outside /system. Look up "Magisk" - it's the systemless solution people are using now, and should work with PHH Superuser as well. I have no hands-on experience with systemless though, so I can't help you much further in that aspect. – Andy Yan Sep 3 '17 at 1:11
  • I can give magisk a try, but i still don't know how to remove phh's superuser completely from my device as that's what magisk requires me to do before installing it. – Wolf Sep 3 '17 at 1:25
0

You should try this using es file explorer. In the dash board of es file explorer, go to tools then turn on the switch for root explorer. After that consider turning recycle bin on for later restores. Next tap on root explorer and a subwindow should open . Select Mount R/W. That's rewrite permission. Still there, you can select uninstall system apps. It should work well. Proceed with caution and at your own risk

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.