1

I recently tried to remove the Google search bar on my homescreen using this tutorial by disabling the Google Search app in settings. It turns out I was using the Google Now launcher, and so when I rebooted the launcher broke and sent me into some kind of recovery mode (not the proper android recovery mode.) It went through the booting animation, but then just came up with an alert saying 'Optimising Apps: 1/150', which cycled through each app and 'optimised' it. Upon completion, a black screen came up and the phone rebooted itself.

I'm using an unrooted Moto G2 which had Marshmallow running on it. I'm wondering how to reinstall my OS or otherwise restore my device; I don't care about data as it is backed up.

Any ideas how to fix/reinstall my Android installation?

  • 1
    If all you did was disabling the Google App then it shouldn't have caused such havoc - try initiating a factory reset from fastboot first. – Andy Yan Sep 4 '17 at 1:00
  • 1
    Would that be the 'Factory' option in the fastboot menu that I get when pressing Power+VolDown? If so, that just does a 'normal' powerup which gets stuck in a bootloop like turning the device on normally. – Tobsta Sep 4 '17 at 5:42
  • 1
    Yeah I meant that. If that doesn't work out for you, you'd have to flash a factory image, also via fastboot. For that you'll need to know your exact model number (should be on the fastboot screen as "XT10xx". – Andy Yan Sep 4 '17 at 6:24
  • 1
    @AndyYan Maybe OP removed the launcher? Does their model come with Google Now? – Death Mask Salesman Sep 4 '17 at 7:48
  • 2
    @DeathMaskSalesman Silly me, I wasn't thinking clearly when I first asked the question. I was in a hurry at the time and I misread the article, assuming that installing a different launcher was a separate solution. I'll update the question now. – Tobsta Sep 4 '17 at 12:00
0

Solved my own question, thanks for the help.

To get into recovery mode on my Moto G2, I first went into the bootloader by force shutting down the bootlooping device (hold power until it turns off) and then pressing Power and Volume Down at the same time for 2-5 seconds. I then selected 'Recovery', which came up with the boot animation and then a dead android with the words 'No Command' written above. I then pressed Power for 5-6 seconds and tapped the Volume Down button, which took me to the recovery mode menu.

I then selected the option 'Wipe data/factory reset' and selected 'Userdata only'. Once it wiped that, I rebooted and waited ~10mins at the booting animation before it took me through the Android setup wizard. All of my data was restored through Google Drive and Google Photos, even stuff like the order in which apps were displayed on my homescreen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.