-5

I'm currently trying to hard-brick my phone. Yes, you read right. The reason doesn't really matter. I tried flashing wrong recovery/ROM but no success. I could easily recover the smartphone afterwards through SP Flash Tool and MTK Droid. It's about a Gionee P6. I can't flash a kernel because it doesn't allow me, the process of flashing ending with error each time. Any suggestions?

  • How about physically? Can you open the device up? – Andy Yan Sep 6 '17 at 10:44
  • @AndyYan I don't want to damage the warranty seals XD – Peter Sep 6 '17 at 10:58
  • I'm thinking of dd zeroes to the kernel partition, effectively zero-filling it. Need root ofc. Not sure if that'll actually work, since normal guys like me don't have the guts to try such risks. If SPFT can't flash a kernel to the phone (as you described) then there should be few if any means of recovery from a missing kernel. – Andy Yan Sep 6 '17 at 11:09
  • @AndyYan How can I do that? I'm not very familiar with sending commands from pc – Peter Sep 6 '17 at 11:13
3

You can easily root the phone (or do this in a working recovery) then run the following command in a shell:

dd if=/dev/zero of=/dev/mmcblk0 bs=1M count=1

Do note that unless you destroy a piece of hardware, a professional engineer can always recover it with special tools.

See this answer of mine: Using ADB, what command can I use to break/permanently destroy a Galaxy S5?

  • 1
    Did the trick, completely unresponsive – Peter Sep 6 '17 at 12:54
  • This is the weirdest case I have ever seen but nice to see that it worked. – SarpSTA Sep 6 '17 at 13:47
1

It's an MTK device. You can easily hardbrick it using SP Flash tool. Go to Format tab. On Auto Format Flag , click on Format whole flash. This will format the eMMC memory leaving practically nothing, not even the preloader. Now click on Start. Power off the phone then connect it to the computer. Wait a few seconds. Done.

PS: One can still bring it to life using special tools though.

  • Can someone detect that this was done purposely? Does it even boot up, like going to boot screen - a blank screen? – Peter Sep 6 '17 at 12:31
  • No booting up, no charging, no detecting by a computer. I don't think someone can figure out it was purposely bricked. – esQmo_ Sep 6 '17 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.