26

On Android Oreo, the option for "add icon to home screen" is no longer in the Play Store settings. How do you disable the option?

migrated from stackoverflow.com Sep 7 '17 at 13:52

This question came from our site for professional and enthusiast programmers.

  • 3
    The right way to do this is to pose the question if it has not already been asked, and then answer it yourself. – user160818 Aug 23 '17 at 16:51
  • Edit your post to make it a question. And answer it. +1 because I was looking for the same thing – Simon Aug 31 '17 at 15:19
45

I've been looking all over the internet for an answer to this for a while. In hopes of alleviating other people's headache's, here's how to enable/disable automatically adding home screen icons of newly downloaded apps in the newly released Android Oreo.

You won't find the setting in the Play Store anymore, nor is it in the Google app settings, or the device Settings. Instead:

  1. Hold on the home screen
  2. Tap Settings
  3. Toggle "Add icon to Home screen"
  4. Rejoice in knowing you didn't search for this for over an hour

Note that this fix is confirmed for the default Android Oreo launcher, tested on the Pixel. Other launchers and devices may differ.

Credit goes to Reece Gale for posting his answer on Google+.

  • 6
    doesn't work there's no such toggle as "Add icon to Home screen" in the mentioned settings . . . – farsiray Sep 16 '17 at 10:41
  • 1
    Scroll way down the page it's at the bottom. Toggle off. – Mike Brodesky Nov 20 '17 at 2:53
  • 3
    @MikeBrodesky as it's a setting of the home screen, it will depend on the launcher. Aaron: could you clarify this and also mention which launcher you refer to? If it's "the default one", please at least mention the device (as "defaults" differ between manufacturers/devices/ROMs). – Izzy Nov 20 '17 at 10:09
  • I couldn't do this as the Google now launcher wasn't compatible (HTC U11). I got around this by installing another launcher called Oreo launcher. (Not by Google) this had the option and was compatible. – James Khoury Feb 17 '18 at 2:08
  • 1
    This option is not available on the Nokia 8 Sirocco for example (running Android 8.1 via Android One). – fritzmg May 14 '18 at 15:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.