I bought a USB-to-micro-USB cable to use my USB on my Android device. Normally, when you plug it in you get a message above that says it is connected. But when I plug it in, the message does not show up on my phone and when I use it on my tablet it works.

I already tried a USB OTG check app and it says that it is compatible. I also tried another USB but that did not make a difference.

Can someone help me?

  • What phone? As the answer below alluded to, not all Android devices support OTG and some only support very low devices or require a special OTG Power Y-cable to function.
    – acejavelin
    Commented Sep 12, 2017 at 11:37

2 Answers 2


Yes it's natural. In some phones the OTG doesn't work, because it's unable to provide the power needed to function the external device you're trying to connect. In your case the tablet gives the power needed while the phone doesn't.


One case that I can think of is that your phone can't supply enough power fo the USB drive.

"USB drive" is a very wide concept because all drives with a USB interface can be called a "USB drive". It can be a flash drive, an portable HDD or even a portable SSD.

Typically, a flash drive only requires less than 1W of power, while a portable HDD can draw as much as 5W, and a portable SSD can draw 6W or more.

Another possible case is that your phone has an Enable OTG setting that is turned off by default. My phone (OnePlus 5) has this case. You must manually turn on that setting. Those apps won't detect it if such a setting is turned off and still tells you your phone supports OTG.

  • I doubt phone can't deliver enough power it's either lack of otg support or it's turned off as you said. Commented Sep 12, 2017 at 12:51
  • @ЈеднорукиКрстивоје The OP said i already tried an USB otg check app and it says that it is compatible.
    – iBug
    Commented Sep 12, 2017 at 15:15
  • My bad sorry... Commented Sep 12, 2017 at 16:43