I'm running MIUI 11.20.90 on my HTC Incredible. I recently updated the Google Search app via the Android Market and now the default search app has changed from Google Search to MIUI's built-in Sidekick search app. To be clear, this is only when single-pressing the hw search button; long-pressing the search button brings up Voice Search (as desired) and the default setting for that action is still configurable. I really prefer Google over Sidekick and would like to change it back.

I tried resetting the default search app but can't - under the Google Search app's properties "Launch by Default" says "No defaults set" and the "clear defaults" button is grayed out. I can't find the Sidekick app in the applications list.

I also tried to uninstall/reinstall Google Search but the market only allows me to revert from the update with the message "Do you want to uninstall all updates to this Android system app?" When trying to uninstall Google Search in the OS I get the error "Unable to remove system application."

I think it's silly to have the Google Search bar/widget taking up homescreen real estate when I have a dedicated hw search button, so I'd really like to find a way to get the default corrected.

2 Answers 2


This in terminal app and restart afterwards did the job for me:

mount -o rw,remount /system
cp /data/app/com.google.android.googlequicksearchbox-1.apk /system/app/QuickSearchBox.apk

Found the answer here.

  • This was easy and exactly what I needed. Thanks so much!
    – Mr. Buster
    Commented Mar 28, 2012 at 17:44

I have couple of additions to the solution dhill provided here. After opening terminal, we need open shell on device with command adb shell. For replacing builtin search, we must replace folder with command cp -r source destination. So, the complete script is:

adb shell
mount -o rw,remount /system 
cp -r /data/app/com.google.android.googlequicksearchbox-1 /system/app/QuickSearchBox

Unfortunately, after system update I must repeat those commands.

  • 1
    There is a problem here. Unless adb deamon is already running in root mode on the device, all of your commands after adb shell would and should fail because the second and fourth command requires root access, which you've not provided anywhere.
    – Firelord
    Commented Jan 9, 2016 at 19:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .