1

I have been waiting for official port of LineageOS to my LG G6 (H870). And yesterday I decided to install the newest version of LineageOS (14.1 20170912) on my G6. I downloaded unlock.bin from LG's official site, unlocked the bootloader, verified the unlock. Then I installed TWRP (3.1.1-0-H870), booted in recovery mode, wiped cache, data, and system partition before I installed LineageOS from zip file (due to the instruction on LineageOS official wiki). I also installed OpenGapps (micro arm64 20170912), and restarted.

Everything worked well until i tried to encrypt the phone. I plug the phone in AC, push «Encrypt phone» button, input my PIN code and verify that I want to encrypt the phone. The phone restart, the phone display the «gear splited» Android mascot (the below one, without the header and progressbar).

enter image description here

But nothing happens, the phone display it for a few seconds before it continue boot process.

I also discovered that «Device Storage» (Settings > Storage Settings) tells med that «-14.01 GB used of 7.40 GB».

Is there someone who has had similary problems? Or know how to fix this?

  • At this early stage the devs might not have implemented it - report back on XDA if necessary. – Andy Yan Sep 13 '17 at 14:03
  • AFAIK that is rom related problem, I saw someone reporting same thing but I can't remember where. You should probably report this to rom developer. – Једноруки Крстивоје Sep 13 '17 at 22:30
  • This LineageOS changelog doesn't show the version you mention, but I do see some unofficial builds with that date. Unofficial builds are often missing features. – Dan Hulme Dec 19 '17 at 13:44
0

It's currently not implemented, the patch needs reviewing or something. I spent several days trying to figure it out. If you're into it, you can merge it yourself and rebuild and it should work: https://review.lineageos.org/#/c/165296/ (although I think this patch is for file-based encryption, there is a separate one for full disk encryption).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.