When I was trying to install apps from google play store, it downloads and then pops the error,

"Application installation failed".

I tried numerous ways described in websites and now the error doesn't pop but when downloading is finished, again it starts downloading. And it causes data loss only.

If there's a solution please let me know.

  • 1
    "I tried numerous ways described in websites" - list whatsoever you've tried so that we don't end up suggesting them.
    – Firelord
    Commented Sep 15, 2017 at 6:24
  • Clear play store cache data and app data, then restart the device and open play store. Force stop the play store app, play services and restart play store Commented Sep 15, 2017 at 6:30
  • 1
    I would guess it is a compatibility problem between your phone/android version and the app. However, it is hard to tell without knowing both Commented Sep 15, 2017 at 12:14
  • The phone I'm using is Panasonic P66 Mega, Android Version: 5.1 Lollipop. It occurs for each and every app. Commented Sep 16, 2017 at 5:22

1 Answer 1


The android version in your phone is incompatible with the play store version. When we update play store, without updating android version, this error occurs.


go to settings --> Apps --> Downloaded --> Google Play Store --> Uninstall Updates --> Click 'Ok'

When you uninstall updates it will be replaced with the factory version which is compatible with any android version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .