0

I have an Samsung Galaxy Tab S2 8.0 It's up to date with everything.

Up until just now, I've never had a problem connecting external storage devices to my tablet using an OTG cable. Earlier today, it worked fine.

Later, I tried to connect a device but it wouldn't mount. I tried a second cable. I then tried a different USB storage device. No luck. I tried rebooting the tablet. No luck. (One of the devices asks if I want to connect and that came on for a second then disappeared. Since then no luck with anything.)

This happened once before and by blowing air into the micro usb port I must have dislodged some dust and it worked. I tried that again but no luck.

The SD card in the SD card slot is working fine.

To recap, I have tried:

Three different OTG cables

Two different USB storage devices

Resart, Turn on and Off, Soft Reset of the tablet.

OTG troubleshooter isn't finding any OTG even when physically connected.

Any ideas on how to fix this?

  • Probably not getting enough power, try with Y cable – Једноруки Крстивоје Sep 17 '17 at 12:37
  • I doubt that's the problem since both storage devices worked fine just prior to it not working. – BuzzB Sep 17 '17 at 19:24
0

USB settings are likely clobbered. Samsung tech support cleared up the issue for me with these steps:

  1. Go to Settings → Apps → click on 3 dot menu → Show system apps → USB settings → Storage
  2. Clear data (will not remove files or personal data)→Settings→General Management→ Reset (will not remove files or personal data)→Reset settings.
  3. Approve all in the second step and tablet will automatically restart.

I tested with an OTG device and mine worked.

| improve this answer | |
  • Please be aware that on older versions of android on this Samsung device when you perform the steps in section 1 and move on to the General Management tab in Settings to apply step two, your only reset options are a Network settings reset and a Factory Data Reset. Both of these options will remove personal file data so BEWARE. – david field Sep 2 '19 at 4:54
  • I tried a modified version the suggestion from Bob Quincy. I cleared the data for the USBSettings system app. But instead of doing a Reset I rebooted. After the tablet finished rebooting, I tried reading an SD card with my OTG reader and it worked. I did this with a Samsung Tab A 10.1" (SM-T510). Thank you Bob. – Paul Parker Feb 3 at 3:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.