0

I have a moto e2 xt1521 handset and I tried to update my OS.

In the process I wrongly typed flashboot flash boot recovery.img instead of flashboot flash recovery recovery.img and I was stuck in a bootloop.

To recover out of it I decided to flash firmware XT1521_SURNIA_RETASIA_DS_6.0_MPI24.65-39_cid7_subsidy-DEFAULT_CFC.xml.zip. I tried installing all the versions of firmware but I was never able to get an IMEI number on my phone.

It shows "IMEI 0". I'm using Slim-surnia-6.0.1.build.2.1-STABLE-20170329-2049. I'm not able to make call or use any cellular services. After a reboot I get an error "Temporary error occurred: 44 ".

EDIT

In fastboot fastboot getvar imei shows my imei number but not with *#06#. So, I don't think I have lost my imei number but the system is not able to read it somehow.

Any suggestions ?

0

IMEI number is generally not affected by any rom customization and you can also get it in fastboot mode. One possible reason of the problem can be that you have not installed correct version of stock rom.

Motorola has different firmware for different country/market.e.g Flashing Brazillian firmware on Indian device can cause problems.

So get the correct firmware and install it.

  • Where to get the correct firmware from ? – Ansh Kumar Oct 6 '17 at 4:03
  • @AnshKumar search it on xda forum you will find it. – Deepak Gangwar Oct 6 '17 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.