I had NetFlix installed on ASUS Eee Transformer and since I am not using it, I uninstalled it.

But now Android Market tells me there are updates, which I do not wish to do, and it acts as though it is still installed. Ok, I went to open it to see the app, and Open just takes me back to the Android Market page.

I see the same behavior on Mobo Video player. I installed it, it said to go get the codecs, so I did, then when I open it, I get sent back to the Android Market page. Tried uninstalling, same basic behavior.

How do I clean these up? They seem to be in some kind of installed/uninstalled limbo.

Running the latest update from ASUS, so Android 3.2.1 and latest firmware.


Sounds like ASUS has installed stubs as system apps. You'd need root to remove them or unlink them from the Market.

  • I can buy that for the Netflix app, and I can probably live with that one. The Mobo Player one is a bit annoying. I seem to missing something obvious about this one. – geoffc Jan 16 '12 at 17:20

I wonder if you uninstalled via some method other than the market and things got out of sync? Settings / Manage Applications or a launcher shortcut, for instance.

I would suggest re-installing both apps, then uninstalling via their market pages.

  • I used Market for both. Though maybe Netflix, now I do not recall... Hmm... Something to think about, thanks. – geoffc Jan 16 '12 at 20:13

Can you once try by clearing the "Market" and "Download Manager" cache and data?

To do so go to Settings -> Manage Applications -> Select "Market" from "All" tab and click clear cache and clear data.

Do the same for "Download Manager"

  • No joy, same behavior on both problem apps. – geoffc Jan 16 '12 at 15:38

You need a cache clean up apps to get rid of all those nasty hanging apps. There you will find that your cache has alot in it. Cleaning it once a day helps with performance also so try to make it a habbit of cleaning it once a day!!

  • He already tried it to no avail. Also please don't spread false information that cleaning cache speeds up your phone. It doesn't. – R R Mar 21 '12 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.