0

I have rooted my Redmi 1s one year ago, and installed TWRP using Twrp Manger, and flashed custom ROM (Cyanogenmod and then Lineage Os). And, now I returned back to stock MIUI ROM. Again, I rooted my device and tried to install TWRP. TWRP got installed (I tried different versions of img and zip of twrp), and I cannot boot to TWRP recovery mode. I also tried fastboot methods to install TWRP which also got failed while booting.

I followed the same steps for rooting that I have done for the first time. Rooted using Super Su (source from miui forum). Checked using root checker, shows status as rooted. Tried to install twrp using, twrp manager(success but can't boot to recovery), twrp official app(success but can't boot to recovery) and rashr (got failed, it tells I have installed twrp already). I flashed Philz clockworkmod using fastboot, and booted to recovery mode. I have less experience with CWM. so, I need to set twrp as my recovery. How to solve?

  • 1
    when you installed TWRP and tried to boot into recovery then what happened? Did you boot into stock recovery? – Deepak Gangwar Oct 2 '17 at 11:22
  • Twrp got installed successfully. And tried to boot to twrp, but, it showed twrp loading screen and remains there long time. So, I installed stock recovery again. And, remains in stock ROM. – Rahul Gopi Oct 2 '17 at 15:58
  • Then I think this is some device specific issue. Although you can try a different version of twrp as your last shot. – Deepak Gangwar Oct 2 '17 at 19:41
  • philz recovery installed through fast boot method and works well. but, with different twrp versions(recovery got stuck in teamwin logo) it fails. Is any issue with firmware? – Rahul Gopi Oct 3 '17 at 2:08
  • 1
    Probably firmware issue. ask this on xda forum they can help better in the case – Deepak Gangwar Oct 3 '17 at 4:01
0

It was a firmware issue. TWRP requires latest firmware/ROM to be installed. Otherwise twrp get stuck at teamwin logo.

I installed latest MIUI ROM (MIUI 8.2.1) on my device and rooted it and installed latest TWRP image(3.1.1) using fast boot. It booted to twrp recovery successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.