2

EDIT: I'm getting similar results in both 32-bit and 64-bit.

Summary

I am installing Android-x86 version 7.1 32-bit or 64-bit in VirtualBox.

If I install it using UEFI (64-bit only), it works, but I cannot resize the screen, a problem to which I have been unable to find an answer.

Therefore, I need to install it without UEFI, so that I can resize the screen.

Problem

The Android installation runs smoothly. But, no matter what I have tried, once installed, the non-UEFI Android system won't boot.

If I use a GPT hard disk, I get this error message when booting the newly-installed Android, whether 32-bit or 64-bit:

FATAL: No bootable medium found! System halted.

If I use an MBR hard disk, I get this error message when booting the newly-installed Android 64-bit:

  Trusted GRUB now booting command list

  Progress:
Error 15: File not found

tGRUB: ******************************************
tGRUB: * An error occured which might result in *
tGRUB: * an unverifiable or insecure system     *
tGRUB: * state. !!! BOOTING WILL BE STOPPED !!! *
tGRUB: ******************************************

And the 32-bit starts with 100% CPU and goes nowhere (very fast!).

More information

Host

  • Linux Ubuntu version 16.04 64-bit
  • VirtualBox version 5.1.28

Guest

  • Type Linux, Version "Linux 2.6 / 3.x / 4.x" (32-bit or 64-bit as appropriate)
  • System Base Memory 2,048 Mb
  • System EFI turned off
  • Storage
    • Controller: IDE for the optical drive to hold the Android-86 ISO
    • Controller: SATA for a 40 Gb hard disk

Question

How can I get Android-x86 to boot on a non-UEFI system on VirtualBox, please?

  • Use Marshmellow as it is the stable build for x86 project. P.S. you should try Anbox – Deepak Gangwar Oct 2 '17 at 10:38
  • Thank you for the ideas, @DeepakGangwar. Unfortunately, 6.0 gives the same error on startup. Anbox looks interesting, but I think that it needs much more work — it doesn't even start on my system (though it installs fine), and anyway it doesn't come with Google Play Store. – Paddy Landau Oct 2 '17 at 16:34
  • Updating Grub also fails. Miserably. – neverMind9 Aug 17 '18 at 0:23
-1

When you try to install Android x86 on pc HDD, try to provide a boot partition through Create/modify partition and make it bootable. Followed by that create a new partition as Linux. write both the partition and after that install the android x86 on the linux partition (formatting as ext4).

It will work, after allocating a bootable partition. I tried and it worked.

  • The question of Paddy Landau was to install Android x86 in a virtual environment of VirtualBox. As your answer only covers installation on a physical pc it does not answer the question of Paddy Landau. – Robert Aug 25 '18 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.