0

Device details:

  • Samsung Galaxy S3 (i9300) with broken screen
  • No System (was running CM13.0 with GAPPS)
  • Currently flashed with TWRP 3.1 with Odin (was CWM)
  • /data | /dev/block/mmcblk0p12 | Size: 11622MB Used: 5540MB Free: 3440MB Backup Size: 5540MB

System details:

  • Windows 10
  • adb-1.0.39

I need to make a valid nandroid or adb backup for Titanium Backup Pro on my new device. What I've tried so far:

  • adb backup --twrp data (also with --compress option) to my laptop but it's currently unrestorable. #1011
  • adb backup without --twrp, results in 0KB file. Tried using adb-1.0.31 as described at question 83080 but didn't work (no password set)
  • backup with CM Recovery v6.0.4.6, but seems to fail on system (not sure). The backup folder only contains boot.img and recovery.img
  • adb uninstall package to create space/reduce backup size. /sbin/sh: pm: not found

Any other ways I can try without losing apps+data?

0

Restored system with what was running before by doing:

  • twrp wipe system (it was already empty, but for good measure)
  • twrp wipe cache
  • twrp install /sdcard/Download/cm-13.0-20160113-UNOFFICIAL-temasek-i9300-V2.9.zip
  • twrp install /sdcard/Download/open_gapps-arm-6.0-mini-20171004.zip
  • twrp install /sdcard/TWRP/SR4-SuperSU-v2.78-SYSTEMMODE.zip
  • twrp fixperms
  • twrp wipe cache
  • twrp wipe dalvik

Aftwards it got stuck in a bootloop. I had Android Studio open to watch the logcat and somehow managed to adb shell pm uninstall packages, just before the Fatal signal 11 (SIGSEGV) error, with the intention to fix the bootloop.

I uninstalled CM 13 themes first as they where appearing before the Fatal signal 11. It got to a point where it was unclear what was causing the bootloop and remembered I had activated a custom bootanimation with one of those themes. Deleted the /data/system/theme/bootanimation.zip, but did not help. Tried adding debug.sf.nobootanimation=1 to the /system/build.prop, but did not help either.

Then I decided to uninstall packages I don't need backing up, as I was planning to try and create a backup again with CWM Recovery when enough space was available. To my surprise I was able to get out of the bootloop! Probably one or more apps were the cause of the bootloop after re-flashing the ROM.

I am now able to use Vysor to backup apps+data I need with Titanium Backup to transfer to my new device.

Alhamdulillah..

I hope this may be of use to someone else who may be experiencing a similar problem.

Options are:

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.