21

I've change the SIM in my Galaxy-Nexus-S. Under Settings -> About phone -> Status there still is the old phone number and I cannot manage to change it.

I've seen this answer which is outdated. The menu option Own numbers discribed in the answer is not there in ICS.

The navigation terms might be called differently, as I manually translated the names from German.

1
  • 1
    The way I had to do it in Gingerbread was to put the SIM into a Blackberry, change the number there, and then it updated when I put the SIM back into my Nexus S. (The number isn't always stored on the SIM, so if it isn't then Android won't update - you need to manually story it, which AFAIK you can't do on ICS/Gingerbread, hence the Blackberry method)
    – TyrantWave
    Jan 17, 2012 at 11:57

3 Answers 3

1

In previous versions of Android (mine is 2.3.7) you can set this setting in the Additional call settings. In Android 4.0 the Additional call settings screen is located here:

Open the Phone app -> [Menu] -> Settings -> Additional settings.

I have not verified this on a physical device yet.

2
  • Thanks for the answer. Unfortunately there is no option to change the phone number here.
    – user10769
    Jan 18, 2012 at 17:50
  • @gentmatt It's there for me.
    – user13391
    May 10, 2012 at 18:57
-1

You need to reprogram the phone. Dial ##786# on the dial pad and then hit view. You may need your MSL to be able to change the phone number.

2
  • 2
    "Connection problem or invalid MMI code."
    – user10769
    Jan 18, 2012 at 18:47
  • @Mr. Monkey "UNKNOWN APPLICATION" is what i get. Are you sure there is not supposed to be additiona # at the end?
    – Boris_yo
    May 10, 2012 at 14:37
-1

Have you tried just a factory reset? Sounds like you got a new phone, right? Any opposition to just wiping and starting fresh? I would think that would do it.

1
  • Ever since I got ICS 4.0.3 on my Nexus S, I had to wipe it twice already :)
    – user10769
    Jan 18, 2012 at 19:58

You must log in to answer this question.