0

I have a new moto x http://www.ebay.com/itm/Motorola-Moto-Z-Play-XT1635-03-64GB-FACTORY-UNLOCKED-5-5-3GB-RAM-Black-White-/202006426506?var=&hash=item2f0885738a:m:m4lAgEM6Gyne3vodvWp9W-w

I just purchased and trying to get rooted.

There appeared to be no lock on the device as indicated ROM

So I uploaded the TWRP image

# fastboot flash recovery twrp-3.0.2-0-addison-eng-modified.img
target reported max download size of 536870912 bytes
sending 'recovery' (14020 KB)...
OKAY [  0.055s]
writing 'recovery'...
(bootloader) Image not signed or corrupt
OKAY [  0.201s]
finished. total time: 0.256s

And then boy, was I surprised to find out that I should of uploaded a copy of the image to the sdcard "first", before I wiped it clean.

Now I can only get to the ROM image splash screen w/menu or the TWRP setup. TWRP ask for that image file locally. There is no externally accessible standard sized sdcard slot on the device (onboard 64gb or 2 nano sim slots only) Note: I have no nano sized sdcard to attempt

I tried to push the image up to the device

# adb get-devpath
usb:2-2


# adb push -p /home/Downloads/twrp-3.0.2-0-addison-eng.img  mtp://[usb:2-2]/
error: device '(null)' not found
# adb push -p /home/Downloads/twrp-3.0.2-0-addison-eng.img  mtp://[usb:002,038]/
error: device '(null)' not found

The file system appears to be in write protect, but I can write a test txt file to the sdcard via TWRP shell and vi.

note: in the TWRP shell, I can see SELinux is active

How do I push the proper image file via USB to my Moto X play 1635-3, or any other recovery method?

Update:

adb push -p /home/brads/Downloads/twrp-3.0.2-0-addison-eng.img  /sdcard/

got the image uploaded to the onboard sdcard. Now my file system is not 'write only' as well. Since the push, I can use the GUI to transfer image files back and forth like cake. The push must of unstuck something I guess.

Image failed to load when I tried to install to /boot partition from TWRP.

Trying suggestion from below now.

1

First, that version of TWRP is ancient, upgrade to twrp-3.1.1-1-addison.img from Alberto97 here. Be aware that in Android File Host, the newest file is not at the top normally, it is at the bottom of the page(s). Once you have the correct file, flash and/or boot from that.

After that, you have two options...

You can use ADB Sideload and "push" the ZIP image of your ROM directly to the device.

  • In TWRP go to Advanced - ADB Sideload
  • On your PC, enter "adb sideload customrom.zip" (replace with actual filename)
  • Repeat for Gapps (if needed)
  • Reboot and enjoy

The second option is to go into TWRP Mounts, and mount Internal Storage, then make sure MTP mode is enabled, connect USB cable and you should be able to copy the files to the phone and flash like normal in your GUI.

The biggest issue you are having is your TWRP is old and does not support the latest bootloader.

For issues beyond that, I would recommend going to XDA's Moto Z Play forums and start a thread in the Q&A section for help specific to your device from people who are intimately familiar with it.

  • That's only old, but can't be too old not to be called ancient. All 3.0+ versions seem to be rather prevalent. – iBug Oct 6 '17 at 17:18
  • @iBug OK, maybe "ancient" is exaggerating a little but, but the one the poster is using the original version for that device, there have been 6 or 7 versions since then... I stand by my the content of my answer. – acejavelin Oct 6 '17 at 18:09
  • @acejavelin where do I get customrom.zip? – NIX Oct 6 '17 at 22:47
  • @NIX that was merely an example, but you can find dozens of custom ROM's at XDA in the Moto Z Play forums I linked above, or go directly to the development section here: forum.xda-developers.com/moto-z-play/development and take your pick – acejavelin Oct 7 '17 at 3:00
  • @acejavelin I got Tipsy installed but it "sucked". It couldn't find my sim ports, the package manager was broke. I was hoping for gravy with you recommending one. – NIX Oct 7 '17 at 3:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.