I currently have an unstable internet connection at home, therefore the router keeps on reconnecting. I am currently trying to fix this.

However, the most annoying thing about this situation is that my phone (Moto G5 Plus, Android 7.0) keeps on spamming the "Wi-Fi has no internet access" notification, including a notification sound and a vibration.

enter image description here

This is especially annoying if this happens at night. I know, that I can turn off all notifications, but I want to stay available for some important ones.

So how do I turn off the sound/vibration for this kind of system notification?


2 Answers 2


I thought there was a way to block certain notifications in android 7.

When this notification comes up just long press it and a dialog will appear. You can select 'Show notifications silently' or 'Block all notifications' for this specific annoying notification.

Hope this helps!

  • 1
    Thanks, I will try it, if I'm fast enough next time. I think, I already did this but nothing happened (the notification will vanish by itself after a few seconds). I know how you can turn off notifications for certain applications, but there is no application associated with that (my phone is not rooted).
    – cero
    Commented Oct 11, 2017 at 12:33
  • @cero tell me how it went when you do!
    – papakias
    Commented Oct 11, 2017 at 14:28
  • 1
    I tried it once, a dialogue opened with the settings, but it disappeared shortly after. So in principal it should work, although I don't know which app it was. But in the meantime I fixed my internet connection and it doesn't appear anymore. However, this should be the solution if it happens again. Thanks.
    – cero
    Commented Oct 13, 2017 at 14:17

enter image description hereenter image description here

Thanks! It solved for me, when the notification popped up, I long press it few seconds and there's an option 'All categories' and 'Done' after pressing All categories it took me to the System settings as in the picture, and on Network alerts I disabled the Floating notification and Sound, The annoying notification were never to be seen again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .