3

Android Oreo came with a new "smart text selection" feature that uses AI code to make smart decisions about selecting text such as addresses and phone numbers.

However, in my experience this works very poorly on my Nexus 5x where I write (and select) a roughly equal amount of text in English and Swedish (system language is set to English). In particular the smart text selection results in Swedish are complete garbage. I have yet to see the smart text selection feature make an accurate guess of what text to select. On the contrary, it very often makes completely illogical selections when tapping words in regular text flow (ie. text not structured as addresses, phone numbers or similar) that seem to have rather random starting and ending points. I always have to tap the intended word again to get the actual word I want to select, and the number of times I have accidentally deleted a large chunk of text due to this feature is driving me nuts.

Here's an example (that works fine in English, but not in Swedish):

If I were to tap "newspaper" in the following sentence the "smart text selection" feature would accuretely select this word (newspaper).

"Regarding the newspaper subscription: I'd like to have it cancelled by the end of the tryout period."

If however I were to write that same sentence in Swedish and again tap the (Swedish word for) newspaper the "smart text selection" feature would select all text from the word "newspaper" to the word "cancelled", which makes no sense. (Note, this example is made up and of course depends on the exact translation of the example sentence)

Please, is there any way I can disable the disable "smart text selection" feature. I have looked all over the settings menu and googled for information, but I have failed to find an answer. Thanks.

Harware: Nexus 5x Software: Android: 8.0.0

  • This annoys me too. In InoReader I usually want to select a word and copy it for Google Translate to give me a definition, but unfortunately this feature (or bug) selects far more text and I have to adjust carefully. Firefox doesn't have this issue fortunately (it seems to be disabled by Firefox). – lilydjwg Nov 16 '18 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.