Sometime back, I noticed that whenever I browse the web I frequently see very intrusive pop-ups (ranging from facebook ads and other promotional material which appear in dialog box-like pop ups) which show an odd link in the address bar, something like:


I don't recall experiencing this before, also I am still using the version as before (20.122xxxx) never updated it. Ironically I have the built-in Ad-blocker enabled, but still they still show (ads).

I can't figure out how to block these specific "interstitial adsense ads". Is there any other way to achieve this on android ?

Edit 1: I tried disabling the data saving features as suggested by Death Mask Salesman, but the problem persists. This leaves me to think the "adsense ads" are hosted on particular websites and not necessarily the server being used by opera mini, but then again the ad block functionality of the browser should be able block these with ease. Shouldn't it?

Edit 2:

I tried using Opera mini beta, to find out if servers were responsible, strangely during my first few weeks of use (around 2 weeks) these " interstitial ads" never came, but only started appearing again recently.

This is a bit confusing as to what could be the cause but I suspect server issues (since during early days of using opera mini beta I never encountered the ads, but perhaps the server was changed to the regular one used by release builds, then the problem resurfaced?

If the latter is true then perhaps the real question is why Opera mini's ad blocker doesn't block self-generated ads?

  • 1
    Do you have a browser setting as to speed up the loading time of pages, perhaps? If so, is it enabled?
    – Grimoire
    Oct 14, 2017 at 20:42
  • Yes I do have that setting enabled, just as before, its only recently I am seeing these ads. Perhaps this has to do with opera servers which block certain ads but not all? Oct 14, 2017 at 21:18
  • 1
    As you may know, in order to speed up the loading time, pages are compressed and delivered by servers belonging to the browser's developer. Try disabling that setting for a while, and see if that helps.
    – Grimoire
    Oct 14, 2017 at 21:22
  • 1
    @DeathMaskSalesman looks like the issue still persists even when I disabled data compression. Also basing from the post view count, it seems the issue is also affecting quite a number of users .. Dec 19, 2017 at 20:34


You must log in to answer this question.

Browse other questions tagged .