0

Synopsis of Issue: Currently I have several backups that do not show an error resoring but for some reason will not boot. Everytime I boot the device from a backup it goes into the WIleyfox boot screen and stays like that.

Background Information: I own a Wileyfox Swift 2x, unrooted and bootloader unlocked. TWRP 3.1.1 is installed. I upgraded the system to Nougat 7.1 [SW46-WF-MARMITE-7.1-TOS089A-RECOVERY[NOUGAT] and everything seemed to function properly albeit with those annoying corruption startup screens. However for some reason I just coudnt get it to ROOT. I took a full backup. So I decided to install Lineage 14.1 [lineage-14.1-20171002-nightly-crackling-signed] with open-gapps. After a wipe I installed Lineage but it woudnt boot despite fixing error7 issue. ...I moved on>>>

I next tried to install Cynogenmod 13.1 [SW33-WF-MARMITE-CM-13.1.5-ZNH2KAS7EB-RECOVERY] with open-gapps and succeeded but later realised there was an issue with ROOTing and phonecall recorder - anyway I needed a working phone so attempted to restore Nougat 7.1 (above) after backing up Cynogenmod 13.1.

This is when i realised that none of my backups would restore. The phone will not boot and all I am left with is the Wileyfox boot screen. I tried restoring with and without system image, & only restoring with boot, system & data - I have performed all of these after performing the standard wipes but it remains the same.

Help: Can anyone help me get my phone into working order so that I can restore my backups and boot into them?

0

I'm not sure how you installed LineageOS and others, but maybe downloading a stock Wileyfox image and following the steps below would work?

WARNING: I did not try it!!

Image found here: https://forum.xda-developers.com/swift-2/how-to/marmite-android-7-1-1-tos118c-fastboot-t3605101 (probably use the fastboot one)

Steps to revert to stock state (copied from here: https://forum.xda-developers.com/wileyfox-swift/general/7-1-1-swift-update-t3592328/page6 ):

fastboot flash aboot emmc_appsboot.mbn
fastboot flash rpm rpm.mbn
fastboot flash tz tz.mbn
#fastboot flash hyp hyp.mbn
fastboot flash modem NON-HLOS.bin
fastboot flash sbl1 sbl1.mbn
fastboot flash splash splash.img
fastboot flash boot boot.img
fastboot flash system system.img
fastboot flash recovery revovery.img

Also, you seem to have installed the lineage-14.1-20171002-nightly-crackling image intended for an old swift (crackling), on the newer swift 2x (marmite). That's probably why it didn't boot, right?

  • Thankyou for your response joosteto and apologies for the delayed response (holiday). I tried to revert to stock state - there were no errors in installing but it would not go past the wiley fox boot screen.... I also tried the fastboot route but command window wont go past "waiting for device" - – Philo Anthropos Nov 13 '17 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.