I have a rooted Moto G4+ running Lineage OS...

Due to fast battery drain, I want to revert to the stock ROM, but I still want to have root. I managed to restore an old backup with no errors.

Now, when I tried rooting it by flashing SuperSu zip from TWRP, it just didn't boot afterwards. It didn't even show Motorola's annoying unlocked bootloader warning. (I could still get to bootloader mode and recovery)

I restored the backup again, then tried to root with other versions of SuperSu, but all resulted in the same black screen and wouldn't boot.

I then tried to root with Magisk by flashing Magisk zip file, but I ended up with the same issue.

I have a strong suspicion that the cause of this problem is the modification of the boot image because both of the zips modified the boot image, yet other zips such as a boot animation worked perfectly fine.

So my question is:

How can I get my device rooted on stock ROM without losing my ability to boot?

  • What is the stock version you are restoring that is working properly, Marshmallow or Nougat? – acejavelin Oct 29 '17 at 14:34

Go to recovery and do "Wipe" or "Factory Reset"

It should help the bootloop problem


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.