After upgrading my Galaxy GT-i9000 to Gingerbread, the vibration when receiving an SMS is unbelievably long and hard. Before the upgrade (2.1?), the vibration was two short vibrations. How can I customize the vibrations, or get the "normal" vibration? This long vibration is not pleasant.

P.S. The vibration intensity config is only applied for the vibration when hitting a button, not for receiving SMS.

P.S. 2: And the camera is extremly slow when taking picture..it is focusing everytime, and it takes 2-3 seconds to take a photo. Before the upgrade it took like millisecond:/

  • 2
    Ask your camera question separately, please.
    – ale
    Jan 21, 2012 at 12:26

2 Answers 2


One option is to disable the notfications from the built-in messaging app (in the Messaging app, press Menu, select Settings and then scroll to the bottom and take the tick out of the Notifications box).

You can then use a 3rd party app that gives you full customization of the notification options, like SMS Popup which gives you control over the vibration duration and pattern, as well as a lot of other notification options.

  • thanks. i have sort of "fixed" the camera. Downloaded an app that cam take out the autofocus and i can snap a picture anywhere on the screen. Though incomming calls is very annoying, because lots of calls i cannot answer :S
    – Henrik
    Feb 29, 2012 at 0:27

I will assume you use androids default SMS app. Open it, go to settings -> notification settings -> vibrate pattern. If you are using a specific SMS app, setting this up might be similar (if the app supports it).

  • Thanks for the reply, but i dont got any vibrate pattern setting in the default sms app im afraid:/
    – Henrik
    Jan 22, 2012 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .