1

So the phone is a S5 SM-G900P, it is stuck in the Sprint logo when booting and the volume keys are broken (power and home keys work).

Developer mode and adb weren't activated in the phone previously

What I have tried:

  • adb (doesn't recognize my device)
  • bought a JIG that gets me to the download mode screen
  • I have flashed 3 official firmwares using odin ( G900PVPS3CQD1_G900PSPT3CQD1_G900PVPS3CQD1_HOME.tar .md5 G900PVPS3CQC1_G900PSPT3CQC1_G900PVPS3CQC1_HOME.tar .md5 G900PVPU3BOK4_G900PSPT3BOK4_G900PVPU3BOK4_HOME.tar .md5).
  • Tried flashing TWRP recovery via odin so i could do the factory reset without pressing keys, it gave me a pass and i was hoping that it took me to that screen after that but same story getting stuck

All the flashing goes smoothly, but like i said gets stuck in the sprint logo on all 3

I've read that going into recovery mode and wiping dalvik cache and cache plus factory reset fixes the stuck in carrier logo screen, but with no volume keys i can't access recovery mode.

So i'd love to hear any input or any ways you guys come across that can help me

Much appreaciated

1

You didn't mention what caused the brick as it can be a hardware issue, a damaged eMMC chip for example.

However, instead of flashing one file, you should try flashing ''repair'' files which are 4 flashable files you can load individually. These files contain the full set of Samsung firmware files. Inside these packages you will get PDA, AP, Modem, Phone, CP, BL, Bootloader, and CSC file.

Download theme from here and flash using Odin.

Fell free to ask if you encounter any problem.

  • well when i got the phone it didn't register the volume keys, and had android 6.0 got it to a repair shop to unlock the phone to use with a local carrier (outside the US) and then tired of the bloatware flashed a custom rom (lineage OS to be specific) when i did that the local carrier stopped working both phone calls and data plan/internet so i decided to go back to the official firmware and that's when the stuck in sprint logo happened. P.D: Downloading the repair firmware from the link right now – MrDuro Oct 30 '17 at 0:12
  • So in this case, the files should fix that. Just load everything correctly. – esQmo_ Oct 30 '17 at 1:04
  • just checking, i downloaded the file now and is a single tar.md5 like the other ones instead of the separated ones you pointed do i proceed? – MrDuro Oct 30 '17 at 1:37
  • The description said 4 files.... Yes try flashing and see the result. – esQmo_ Oct 30 '17 at 1:44
  • It worked!!!!! thank you so much! I have been trying for weeks and read all the internet. Wish i could give you thumbs up but i dont have enough reputation for that – MrDuro Oct 30 '17 at 4:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.