7

I'm fairly new to the Android platform so hopefully this is a silly question, but since I've had my Pixel (Pixel 1, Android 8.0.0), it's been giving me notifications for alarms I set in the Clock app two hours prior to their occurrence (disregard actual time in the screenshot). Note that I do not want to delete the alarm, just this notification about it.

enter image description here .

I know this isn't a huge issue, but it's just more annoying notification clutter that I don't want. What's weird is, I've apparently found the settings to change this behavior - but the toggle is disabled and I can't modify it.

enter image description here

Is there another way to do this that I'm missing, or a way to enable that toggle?

  • What if you toggle the allow notifications to off. And anyway hope did you get to the second screen? Are you using Google clock, cuz i didn't find the notifications screen you're at. – aBochur Oct 30 '17 at 22:10
  • @ A Bochur - that toggle controls the "allow notifications dot" setting which dictates if it shows the blue dot on the app icon if there's a notification (it took me a minute to notice the "dot" in there). I reached this screen by holding down the "upcoming alarm" notification and then selecting "all categories". I can provide a screenshot of that if it would be helpful. – jszpila Oct 30 '17 at 22:25
  • (My bad, didn't see the dot.) Now, on my phone when i long press on the upcoming alarm notification, it bring up the default notifications settings asking if i wanna block notifications. Apparently on your phone it's different. Is it the same when you go to settings>apps>clock> notifications? If you're able to block it from there, the alarm will still sound but you will not have a notification about snoozing. – aBochur Oct 30 '17 at 23:22

11 Answers 11

3

After spending an hour on the phone with Google tech support (don't know why I didn't think of this earlier) their representative was able to replicate the issue.

At this time there appears to be no way to disable this notification on a stock/unrooted Pixel. I'll update the answer if I get any further information.

| improve this answer | |
2

A long press 'upcoming alarms' will bring up another screen where you can customize the 'upcoming alarms' notification category.

| improve this answer | |
  • But it says "Notifications from this app can't be turned off". And I found no way on that other screen to turn them off. – Kyralessa May 9 '18 at 12:11
  • This one worked on Pixel 2 with Android 10! – julian-alarcon Nov 4 '19 at 21:47
2

This is from a Mate 20 Pro with Android 9, and Google Clock app version 6.2. It is now possible to disable the annoying notification. For me, it was SO annoying, because I use a Garmin smart watch that vibrates when a notification arrives, and it ended up waking me up 2 hours earlier!

Clock app notifications settings

the settings about next alarm notification

turned off the dreaded setting

system details

Sorry for the screenshots language, it's in Italian which is my native language, but I hope that they can help

| improve this answer | |
  • I have Android 9 on the Pixel 3XL. I have the same issue with smartwatch waking me up 2 hrs early. My settings for the Clock app look entirely different. Could you state exactly which setting you changed to disable the advance notification? – tim11g Mar 2 at 11:35
  • In Italian, it is "Orologio" -> "Prossime sveglie" -> "Consenti notifiche" -> Off. Screenshots show each page, one after the other, until the setting is set to Off. Last screenshot shows the EMUI version. – gog Mar 3 at 14:01
1

I managed to do it by setting an alarm and waiting for the notification to come up. Long press and go to more settings. Weirdly, as you said, it's already disabled but if you tap on the bottom line with the disabled setting you get a new menu and then select notification priority (the top option) and select "low priority".

| improve this answer | |
  • Alas, this doesn't actually disable the alarm; it just makes it less obtrusive. Other things that pass along the notifications (like Microsoft Band) will pass along the pre-alarm alarms. (I can selectively disable the Clock app from being allowed to send notifications to the Microsoft Band...but presumably that disables the actual alarms too, and not just the stupid pre-alarm alarms.) – Kyralessa May 17 '18 at 14:36
1

Well, this is a late response but I just ran across this as I am having the same problem. Thank to jszpila here for posting Google's response so I didn't have to waste any more time trying to get rid of the "upcoming alarm" notification.

As a work-around, I changed the sound for the "upcoming alarm" notification to "None". The notification still comes up but it is unobtrusive.

IMG:

| improve this answer | |
0

Not entirely sure, as I use a modified 7.1.2, but I got the impression you could disable individual, or at least app-wide notifications, by swiping to the side and tapping the settings button.

Also, in MM / N there's a menu somewhere in the notifications settings that let's you block notifications from an app, I know that for sure. As I said before, I don't use Oreo, though if I found a ROM for my device that did, I would.

Let me know if this works, or if it doesn't.

| improve this answer | |
  • @N 3 V 3 R A H T yeah, that's what gets me to the screen displayed in the second screenshot. The issue being that the toggle that would control that functionality is both on and disabled by default, so I can't change it. – jszpila Oct 30 '17 at 20:02
  • Do you have power notifications enabled, or is that a Resurrection Remix only feature? If not, go into notifications > the settings wheel in the right corner > Power Notification Controls and turn it on, assuming you have it. If so, go to notifications > Clock, click on the A symbol under "importance", and set the bar next to it to the farthest left. Again, keep in mind that I'm using a custom Nougat ROM, and that this might not exist on stock Oreo. – N 3 V 3 R A H T Oct 30 '17 at 20:13
  • I would also suggest rooting and flashing a custom ROM anyways, it adds a ton of functionality to your device, especially if you like insane customization like me. You can also do a lot more in terms of blocking things, and removing unnecessary system apps. – N 3 V 3 R A H T Oct 30 '17 at 20:15
  • Rooting: forum.xda-developers.com/pixel/how-to/… I have to go, let me know what you've figured out, and tell me if I've helped at all. – N 3 V 3 R A H T Oct 30 '17 at 20:18
  • I'm not totally against rooting but I've had trouble caused by carrier updates in the past, and it really seems like overkill for this situation. I'll do some reading on it, though. – jszpila Oct 30 '17 at 22:26
0

Disabling notifications stopped the 2-hour-early reminder for me without affecting the alarms themselves.

| improve this answer | |
  • Did you intend to reply to this answer? If not, consider mentioning how you disabled the notifications so that others can benefit more easily from your solution. :-) – Firelord Nov 29 '18 at 12:50
0

There is a function called "alarm skip" that lets you dismiss/turn off an alarm two hours before it rings. I hadn't realized that I had turned it on, but I was missing alarms because of that notification (and dismissing it turns the alarm off). I turned off Alarm Skip in settings, and things should work better now. Sharing in case someone else needs this.

(ETA: I'm on an LG V35 ThinQ so I don't think my phone is completely stock Android, but perhaps looking for some variation of this function will help you find the setting to turn it off?)

| improve this answer | |
  • Welcome to Android Enthusiasts. The OP is trying to disable the alarm notification, not skip the alarm. – Reddy Lutonadio Mar 15 '19 at 22:20
0

Install AutoNotification which can be flexibly configured to block almost any notification.

Install the app.

  1. Make sure the Upcoming Alarm notification is active (set an alarm for a few minutes time if not)
  2. Open AutoNotification
  3. Choose Notification Blocking in the Standalone Features section.
  4. Touch the +
  5. When asked for help setting up the block filter, Press Yes
  6. If you have more than one notification active, it will ask you which one to use - tap on Clock: Upcoming Alarm.
  7. Choose Title when asked about about Title or Text.
  8. Press OK if it tells you about Partial Blocking.
  9. The Filter setup screen should already be pre-populated with the right information, on my phone it looks like this:

enter image description here

  1. Press OK and you're done - the Upcoming alarm notification should disappear.
| improve this answer | |
0

I've found a partial answer, after going to

https://support.google.com/android/answer/9079661?hl=en#contact=1

selecting the Samsung helpsite, and chatting with Pete.

He instructed me to go to Settings > Accessibility. At the top of the list was something that said "Using 2 functions". I was able to turn off the upcoming notification of notifications in Timely there.

The Timely timer still doesn't have any sound. (I've added "The Clock" to my list of apps to have a timer that rings.) Nudnik works, but it still doesn't unlock my screen. And I still haven't figured out how to turn off the damned bubbles that are cluttering up my screen.

But avoiding 25-minute advance notifications of notifications is progress, at least.

| improve this answer | |
0

https://www.androidsage.com/2018/08/09/how-to-enable-system-ui-settings-on-any-android-device/

Install a System UI Tuner launcher, then go to Status Bar. Scroll down to Alarm and turn off. Now the Alarm icon will be hidden from the status bar.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.