2

I use hosts to block some sites, which works in WIFI connections,

but when I am in LTE mobile network, these sites seems accessible, I thought somehow android ignore the hosts.

I am in Lineages OS 14.1 (android nougat)

anyone knows how to fix this?

  • Any VPN involved maybe? Not sure whether that's really relevant, but it's the first thing coming to mind. – Izzy Oct 30 '17 at 17:00
  • This is most likely due to proxy enabled in your APN settings, you can try disabling the setting first and see if the hosts are still blocked. – xavier_fakerat Oct 31 '17 at 16:49
  • 1
    @xavier_fakerat Since that was the correct answer, would you mind posting it as an answer so the questioner can accept it. – Dan Hulme Nov 1 '17 at 9:10
1

As already suggested by OP, the issue was caused by proxy in APN settings.

Disabling proxy in APN settings (which interferes with host blocking usually by ignoring the hosts file) solved the issue.

  • thanks for your hint, I finally manage how to set up an APN without proxy, and problem solved. Didn't know had a default proxy there. – anyone Oct 31 '17 at 19:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.