0

I am trying to root my HTC One S. The bootloader is *** UNLOCKED ***, TWRP is installed, and it's S-ON.

From these instructions:

  • I downloaded SuperSU-v2.82-201705271822.zip from the TWRP / FlashFire installable ZIP link.
  • I did adb push SuperSU-v2.82-201705271822.zip /storage/sdcard0/foo
  • I booted into TWRP and installed the above zip. Apart from complaining that /data could not be mounted (EDIT: fixed this by turning off encryption), it claims to have worked.
  • I wiped the cache and rebooted.

Nevertheless, if I adb shell and su I get /sbin/sh: su: not found.

There is a /supersu/ directory which contains su and some other stuff, but I can't run /supersu/su: permission denied. The find command finds no other file on the device matching /su$/.

I also tried flashboot boot superboot.img to get Superboot, but if I do this, the device does not boot past the initial splash screen (the one saying "This build is for development purposes only...").

What went wrong?

  • The failure in mounting /data may signal that the phone is encrypted. As of now, you have a half-working SuperSU. – Death Mask Salesman Nov 1 '17 at 23:29
  • @DeathMaskSalesman I ran recovery --wipe_data --set_filesystem_encryption=off and now the /data warnings go away, but su is still not installed. – spraff Nov 2 '17 at 0:21
  • Did you reflash the SuperSU .zip? – Death Mask Salesman Nov 2 '17 at 0:22
  • Yes. Wiped everything I could and reflashed that zip. – spraff Nov 2 '17 at 0:23
  • @DeathMaskSalesman I also tried Superboot, see edits to question. – spraff Nov 2 '17 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.