0

When I connect my phone to the charger it indicates its charging but the charge is actually dropping. I disconnected the cable from the ‘head' of the charger and tried using my friend's ' head' and it worked fine. What could be the problem with mine???

  • What do you mean by "head"? The charger that plugs on wall and has a USB output? – iBug Nov 2 '17 at 23:21
  • Yes. The kind of charger that has a plug and usb cable seperate. Like the one below – BryanJ Nov 3 '17 at 3:00
0

I have had this experience too. There are a couple of possible reasons that I have found:

  • your phone is using more power than the charger is supplying
  • your phone has detected the charger is connected but is not being charged

The first, and possibly most obvious answer is that your friend's charger supplies more power than yours. Check the current rating on the charger, is it 1A, 2A, etc. But usually the charger, if it is the one supplied with the phone, should be charging the device whatever the current rating.

enter image description here

When the phone has been using more power than it's getting from the charger (with a 2A charger) I have had the screen on and usually some apps running. Closing open apps and locking/turning off the screen has usually fixed this.

The second, and usually more common problem that I had (with my previous phone) was that the connection wasn't always "good" on the phone's micro-USB. I use the quotes because I had no problems with transferring data over the USB connection yet the phone wasn't charging. Simply unplugging and re-plugging the micro-USB connection usually fixed the charging issue. Weird.

  • Love the Samsung's 5.3V charger ❤ It charges everything I have, including my RPi's and Chinese Windows tablets. – iBug Nov 3 '17 at 3:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.