After a recent Android update, about a month ago, "gboard", the built-in Google keyboard on my Nexus started crashing. This made the phone completely unusable, of course. With some effort, I managed to install an alternate keyboard -- Swiftkey -- and this made most of the gboard crashing go away.

But not all of it. Every hour or so, I still get an "Unfortunately, gboard has stopped" dialog box that locks my phone until I ack it. This is rather problematic if I'm using the phone for something else, and (for example) will cause my alarm clock app to not go off.

So, question:

How do I stop the "Unfortunately, gboard has stopped" dialog from ever happening again, short of a factory reset?

Can I reinstall or uninstall gboard? How? Can I surpress the error dialogs? Is there some other solution to this?

(Note: "wait for some update to fix the problem" is not an answer; I have no reason to believe that this is a general enough issue that Google will ever fix it)

  • Is gaining root privileges an option?
    – Grimoire
    Commented Nov 2, 2017 at 21:31
  • 1
    Can you disable gboard in settings>apps>gboard?
    – aBochur
    Commented Nov 2, 2017 at 21:44
  • Also see if gboard works fine in safe mode. You can also try uninstalling updates for gboard, see if that helps.
    – aBochur
    Commented Nov 2, 2017 at 22:14
  • Disable GBoard. Commented Nov 3, 2017 at 4:51
  • 1
    This still happens in Nov 2019 on some devices.
    – sunlover3
    Commented Nov 5, 2019 at 13:44

3 Answers 3


It's very easy - just follow the instructions below:

Open Settings/App Management/Gboard/Storage;

Then clear up the cache and you are good to go! If it does not work even after this step, you have to follow the exact same instructions but instead of clearing cache you clear data. That is a sure shot method to get it to work, but I do not recommend it before you clear cache as when you clear data your preferences are reset.

  • Thanks! I can't test your instructions, though, because I've since replaced that phone.
    – FuzzyChef
    Commented Jul 29, 2018 at 6:30
  • 1
    Selected this answer based on @Beard Of Dan's confirmation. Thanks!
    – FuzzyChef
    Commented Dec 16, 2019 at 22:23

Ok I have just fixed this on my Motorola phone (the problem has just recurred very widely this December 2019). I believe an update has been rolled out to solve the problem so the issue is, how to get your gboard updated if it hasn't happened automatically.

"Gboard stopped working" kept popping up on my screen while following through on the process below, so I had to keep selecting "ok" every time it popped up, giving me small windows in which to perform the necessary actions.

Go to the Play Store, search for Gboard (SEE BELOW) and identify the app (which had its icon next to the word in the search options that came up for me) and select it. You should then have the option to update the app. Select update. After the installation finished everything was working again for me.

IMPORTANT To enter Gboard into the search bar you cannot use the keyboard. So select the microphone at the right-hand end of the search bar and speak, "Gboard" - i.e. use voice to text.

  • This solution worked for me on a Motorola phone. I couldn't find the setting referred to in Jinen's answer. Thanks so much!
    – glyn
    Commented Dec 18, 2019 at 7:05
  • Glad it helped 😃
    – Straight
    Commented Dec 18, 2019 at 11:02

Having solved this problem, I can affirm the answer given by Jinen Setpal. Not having 50 reputation, I can't make a comment, so I'm saying this as a separate answer.

When I had this problem, not every button was responsive (even if there was a slight cue in the UI that it had been pressed). This prevented me from simply clearing the cache for Gboard, so I had to clear the data (I think it was around 60mb, then it went to about 40 something kb). Just as Jinen Setpal noted, there was a confirmation popup that warned that all of the data for that app would be deleted, even from databases (meaning that there is no backup for it).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .