0

So the problem I am having after a Windows reinstall, is that whenever I call ADB, it just gets ignored.
Calling adb from my custom tools seems to be working (have a d.bat file, that calls python, that calls ruby, that does some advances magic with adb, the d.bat is in environmental variables, so just writting 'd' in cmd calls it fine. Why the bat -> py > rb? don't ask. It works. I use it for work..)

If I path to adb (D:\Android\sdk\platform-tools) then adb is called fine. From anywhere else - nope. But the same path is in Environmental Variables, I restarted the command lines to make sure it takes affect, that didn't help, so even restarted the pc. Still nothing. I'm out of ideas. Would be great if anyone is able to help..

CMD: https://puu.sh/ydFo9/7b9b58f456.gif
Env: https://puu.sh/ydFqh/0d8717dce0.png

  • My guess would be there's some executable called adb somewhere else in your PATH (which would explain why calling the right one with full path does work). Not sure how to check that on Windows; on Linux I'd use which adb to see what's used by default. You could manually check each PATH in your ENV if there is some adb.(exe|bat|cmd|*) file – it's not that many places :) – Izzy Nov 3 '17 at 8:03
  • @Izzy Yep. Im retarded. My own files are named adb.py and adb.rb... Bumped sdk folder to the top in Environmental Variables and now it works... Thanks : D – xTheEc0 Nov 3 '17 at 8:16
  • Glad to read it really was that simple – and thanks for self-answering your question (upvoted)! – Izzy Nov 3 '17 at 9:53
1

Izzy was correct. My own files were fighting with the sdk's. Bumping '\sdk\platform-tools\' to the top of the Environmental Variables list fixed it..
Probably should also rename my files to not 'adb'.. But they have a lot of dependencies on each other so that's on 'TODO' list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.