0

My Moto X 1st edition (XT-1060, career Verizon, OS 5.1) doesn't stay rooted. I mean to say that it turns back to unrooted state wherever it reboots or even when it is left untouched for an hour or so. Any system apps that I've uninstalled while rooted also shown in super user applist and any other root related changes e.g changed font also reverts back..

I've tried many tools to preform root operation like iRoot but none of them does the job. Kingo Root however does the job but as I mentioned the phone reverts back to unrooted state after being rooted.

Moreover, all the tutorials and guides about rooting my phone mentions in the first place that I need to unlock the bootloader first. I have tried the official method for unlocking the bootloader but it simply does not work. Just to mention, official method requires following of some steps after which phone shows some strings and you can paste those strings on Motorola's site to know if your phone has an unlockable bootloader or not. They say my phone's bootloader cannot be unlocked. It is also not the developer edition of Moto X otherwise the things were much easier. It is a carrier specific version of Moto X i.e. Verizon and the official Moto website says about such phones that:

Please keep in mind there are many factors as to why a device is or is not unlockable. Carrier exclusive models are almost never unlockable

So my question is that:

Can I somehow unlock my phone's bootloader or root it?

My actual concern is about rooting it so if it can be done somehow without unlocking the bootloader, I'll be more than happy. I included bootloader unlocking as a part of my question just because I cannot see any way without doing so.

  • You are probably not rooting it properly. How do you do that? – Једноруки Крстивоје Nov 3 '17 at 23:18
  • What have you used to root your phone? – Oggy Cather Nov 4 '17 at 2:10
  • I should have mentioned it in the first place but now I've edited it. Please have a look at it. – User5 Nov 4 '17 at 5:53
  • Root the phone by flashing superSU.zip from twrp recovery (bootloader has to be unlocked) – Једноруки Крстивоје Nov 4 '17 at 10:21
  • How can I unlock bootloader while my phone is unrooted – User5 Nov 13 '17 at 10:22
0

I have the developer edition of Ghost, so never had this problem with unlocking the bootloader. Did you try RockMyMoto? You probably have the camera patch by this time, so this might be the method you need.

If that works, I suggest you flash one of the 7.1.2 ROMs over there at XDA after you get TWRP 3.1.1. Mine is rocking Xperience right now. Your phone will thank you :)

  • This does not work I tried but perhaps it is specific with the developer edition of Moto X I cannot proceed with the second or onwards steps :( – User5 Mar 25 '18 at 18:00
-1

King Root will root your phone . After this you can install other 3rd party apps to download and flash custom ROM's before it gets un-rooted again.

Google play offers many custom ROM apps.

So root your phone with King Root Install custom ROM(OS) That's it.

But while selecting ROM's to flash , make sure they are specifically compatible with your device , this is very important to avoid bricking your phone !

Good luck !

  • I've tried King root as well. It doesn't do the job. I've tried almost every app which claims it can root but still I reach nowhere. And don't worry I'll not brick my phone I just need a chance :( – User5 Apr 22 '18 at 17:18
  • you said it only unroots after a while , so flash it with a rom with that time – theenigma017 Apr 28 '18 at 13:01
  • That time isn't just enough plus to flash with a ROM, I need to restart it and upon reebooting it reverts to its previous state as I mentioned – User5 Apr 29 '18 at 9:15
  • have you tried pressing the combination of buttons upon booting to unlock bootloader , maybe you can then flash a rom with a file from sd card – theenigma017 May 1 '18 at 13:05
  • Can you please elaborate it more how to do it? And my phone does'nt support sd card if its worth mentioning – User5 May 4 '18 at 17:53
-4

check permissions maybe you have virus. you can connect with adb and remount disk mount -o rw,remount / chown root:root / chmod 777 /

  • 2
    Sure: if something goes wrong it must be a virus. Only that there is no virus for Android. Second, do you really think it's a good idea to mess with permissions like that? 777 means everybody having full access. Which, security-wise, usually is a very bad idea. Apart from which, why should that make root "stick"? – Izzy Dec 6 '17 at 8:14
  • @Izzy no virus for Android really? There are botnets for Android although less common then on the desktop. google.com/amp/www.zdnet.com/google-amp/article/… niyas answer is bad either way. – William Mar 25 '18 at 18:41
  • @William read the definition of "virus": a botnet is no virus. An apple is a fruit, but a fruit not necessarily an apple – and so a virus is malware, but a malware not necessarily a virus. – Izzy Mar 25 '18 at 19:13
  • @Izzy Yes but the technical requirements are quite similar such that if one exists another quite likely will also. A security issue is a security issue. Depending on the source a botnet can involve a "Cybercriminals use special Trojan viruses to breach the security of several users' computers, take control of each computer and organise all of the infected machines into a network of 'bots' that the criminal can remotely manage." usa.kaspersky.com/resource-center/threats/botnet-attacks – William Mar 25 '18 at 19:26
  • 1
    malware or virus is quite similar to me since i don't use english as full time language.actually there is no thing you can go backward since attacker is here using chmod 777 you gain access..he still have to.. – Niya Yamaha Mar 28 '18 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.