1

I recently saw a thread about a modded systemui on XDA here and downloaded it. I replaced my present systemui with this one and rebooted my phone. I think that at first the replaced systemui didn't work so I got a systemui-less experience (You can learn about my experience by reading the comment I made on SO here ).

Then I learnt that I hadn't set the permissions rightly so I changed the permissions of the new systemui to 644 as said at XDA and rebooted my phone.

After the reboot my apps were optimized as it happens after an update. But this time the new systemui worked (probably) as I now have an all black screen after my phone boots normally.

I then tried to enter into recovery mode and wiped the data (factory reset option) and booted again, but that was of no use as the problem persisted.

What can I do now? Will I have to go all the way reflashing my phone? Could anyone suggest a better option as reflashing seems to be the last option for me. Thanks in advance.

Phone model: Lenovo Vibe C, 16 GB variant, currently running Android Lollipop.

EDIT

  • It was all my fault as the mods were meant for Samsung galaxy alpha (I did not read the title at XDA before messing up)

  • I don't have a custom recovery installed nor do I have a NANDROID backup made before. I'm completely helpless.😭😭

  • 3
    You've learned it the hard way then: Before tampering with system files, always make a backup – especially from files you replace. With some luck you can find someone using the same device and Android version you're running, who can give you a copy of the files you've replaced. But Android.SE is not the place to ask for "an app, device, ROM, accessory or off-site resource" (quote from closure reasons). – Izzy Nov 5 '17 at 23:28
  • But even if I get the systemui, how I'm going to place it back. As I've said that I'm now stuck at a black screen. I'm not asking for the file but want to know how to place it back to restore my device without having to reflash it. – jyoti proy Nov 6 '17 at 4:34
  • Ah. Best option would be using TWRP, which even has an integrated file manager. But if you hadn't yet unlocked your bootloader, that would mean a factory-reset – in which case you're better of doing a "dirty flash" of your ROM (provided you're flashing the very same you're using now, that shouldn't be an issue). If you had USB debugging enabled, you could also place the file using ADB. – Izzy Nov 6 '17 at 6:53
  • If you succeed, be welcome to answer your own question :) – Izzy Nov 6 '17 at 9:15
0

Your best bet would be downloading your stock ROM from online, take the SystemUI.apk and put it back where it should be.

  • How can I put it back there without a reflash? Can you guide me? Is there any other way in which I can access my system files without having to boot into my os and place the files, as when I boot into the os all I see is a black screen. – jyoti proy Nov 6 '17 at 4:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.