I am running AOS 6.0.1 (API-23) on a non-rooted phone. It's been working perfectly for months, but one day after updating some apps like Uber, Viber or Windy, I was told that Google Play services need to be updated as well and would not work properly, until then.

I then updated Google Play, Google Play services and Android System WebView, but then none of their maps was working, meaning that maps based on Google maps are just showing an empty blank map canvas without any features except the pins. I.e. showing the cars in Uber but no background map.

Somehow, after having installed all and everything Google related for my device, the in-app-maps was working again. Unfortunately, I have no recollection or idea what I did at the time that made it work.

Unfortunately now, 6 months later, I have the same problem again after some updates but this time I can't get my maps back. Although Googles own Google Maps, always seem to work... Nowadays I always use apkmirror to download, since they show the relevant app variations and are simply better that Google Play Store, which I no longer use. Here for example, is what's shown for Google Play services:

GMS variations

My device is a "440", at least according to the original firmware versions.

  1. What Google related apps are responsible for showing the in-app-maps correctly?
  2. On what do they depend? (I.e. How are they related?)


3 Answers 3


Most surprisingly, after reverting and/or updating some of the relevant Google apps, some settings got restored to some previous values. Those may also include permission settings and in my case, the Data Usage settings.

I solved this by first ensuring that the following 2 system apps were up-to-date:

  1. Google Services Framework * (com.google.android.gsf)
  2. Google Play services (com.google.android.gms)

Note that GSF is normally never updated and remains fixed for your AOS API version.

Next, I went to check the permissions of those apps. That's when I found that Mobile data had been mysteriously disabled under data usage. Check by navigating to:

Settings > Apps > Google Services Framework > Data usage > Mobile data: "allowed"

Check both Mobile data and Wi-Fi tabs, and for both apps above. That fixed it!

For completeness, also check: Settings > Data traffic management > Networked apps and check that data is available on both the tabs Installed apps and System apps.

But since you're on it, you might as well also update:

  1. Android System WebView (com.google.android.webview)
  2. Google Play Store (com.android.vending)

If you still have map problems after this, then (a) make sure you're using compatible binaries (APK) for your specific device (API, DPI, arm version etc) and (b) that the permissions for all of these apps are as allowing as possible. Also, the device clock need to be correct...


You need to clear the ca cache by going to Settings > Apps > Google Services Framework > Storage > Clear Cache and Settings > Apps > Google Services Framework > Storage > Manage Space -> Delete All Data

I followed this video https://youtu.be/gBc5eIPOKWQ

Solution worked for me in Oreo version. Please node naming convention and path to reach cache could be different in different OS versions. But basics are same.

Best of luck.


If you use an Android system review and the device has a slow internet connection, it is very common that when you install an application on the device, the application will not update itself and instead the Android system review will show the version number of the downloaded application. This problem can be fixed by downloading the latest Google Play Store app to the device and then you can then update the application.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .