0

I have a Micromax Canvas A1 device (Android one). It's been rooted and I have removed some system apps on it before. When I disabled Google App, a lot of space was freed and the system worked fine. So I thought I could free some more space by uninstalling the app without any harm. But when I uninstalled it, the 'searchbox stopped working' message came up. I powered off and then on again, but the boot doesn't complete. The android boot animation keeps running endlessly. Tried entering recovery mode, couldn't. Micromax logo is all it shows. Tried the same with adb, it says 'insufficient permissions for device'.

How do I fix this?

  • Can you list apps that you removed ..and yess reflash your device with stock rom – Nishant Tiwari Nov 8 '17 at 19:32
  • Removal of Google Apps application caused the problem. Yes, I have flashed stock ROM. It works now. – Deepak Maurya Nov 10 '17 at 6:14
0

Reflash the Android One OS by booting into recovery.

First get into the bootloader:

1) Power off your device and wait 4-5 seconds after lights go off.

2) Press and hold Power + Volume Up button together for a few seconds and then release the buttons as soon as you see the boot menu screen

3) Boot into recovery. Flash the Original ROM using TWRP or stock recovery

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.