0

This question already has an answer here:

My Samsung Galaxy Tab A (model number SM-P550 if you want to know the specs, Android version 6.0.1) will not allow me to "unhide" or "unlock" my developer options no matter how many times i tap the build number. On another note i am unable to root my device and because i do not currently own a pc and i have tried every mobile rooting technique i could find, thank you for adressing this issue. Edit - so i finnally figured it out, this device has many "accounts" and you can only access thing like the dev options on the "owner" but i was using "guest" but i still cannot root but im sure i will figure it out eventually, thank all of you for your suggestions and help!

marked as duplicate by Andy Yan, Izzy Nov 12 '17 at 11:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    What does "will not allow me to access" mean? What did you try, and what happened? – Dan Hulme Nov 7 '17 at 13:11
  • Did you try tapping on the build number 10 times in the "About Device" section? That enables the developer options. – Wrichik Basu Nov 7 '17 at 13:24
  • What i mean by access is no matter how many times i tap the build number and no matter what else i do i cannot "unlock" or "access" the developer options. – Mikkei Combine Nov 7 '17 at 17:30
  • Look like you're running a quite old AOS version (6.0.1) from early 2016, and unfortunately Samsung are notorious for buggy firmwares. I'd recommend you to look for a different updated firmware and try that. Or if recently bought, take it back to your shop. As WillW said, all shop bought Androids should have this possibility, unless you got a stolen device that have been blocked somehow. – not2qubit Nov 8 '17 at 15:24
  • Could you edit your post to include all the relevant information? If people have to watch a video to understand what your problem is, they're much less likely to try to help. It also makes it less likely that your question will come up in search results. – Dan Hulme Nov 8 '17 at 19:59
1

Every Android should be able to get developer options. Wrichik Basu's comment says how to show developer options. However OEM Unlocking (first step to root) is disabled on basically all Samsung phones.

  • Yes i know how to do it but it wont work, nothing i do works. – Mikkei Combine Nov 8 '17 at 14:12
  • hymm, interesting. Try deleting cache for settings as per the later portion of this video: youtube.com/watch?v=94qQbr_J9cw – WillW Nov 8 '17 at 21:51
  • next resort is update to android nougat – WillW Nov 8 '17 at 22:21
  • I tried clearing the data of the setting app as the video said but the developer options still will not "unlock" no matter how many times i tap the build number. – Mikkei Combine Nov 8 '17 at 22:53
  • -WillW- how do i do that? – Mikkei Combine Nov 8 '17 at 23:13
0

Can you access recovery if yes then click apply update via adb...then do a Fastboot into a custom adb enabled recovery like twrp or cwm

$ fastboot boot /tmp/cwm.zip

Or

$fastboot flash recover twrp.img

After booting into recovery you can have your ADB enable also then you can root your device

  • But adb requires USB debugging mode enabled, which is in the dev options. Anyways he is at a dead end. – jyoti proy Nov 8 '17 at 20:46
  • Sounds like a good plan but unfortunately i dont really understand what most of that means. – Mikkei Combine Nov 8 '17 at 22:48
  • Samsung devices have no fastboot. – Andy Yan Nov 8 '17 at 23:58
  • I do not know how to access recovery mode, but im sure i can figure it out. – Mikkei Combine Nov 9 '17 at 0:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.