0

Well some people here have came across this question I posted few days ago. I want to inform them that I had to reflash my phone (and I'll edit the details there as recommended by @Izzy)

Device: Lenovo Vibe C Android: Lollipop 5.1.1

So now after a reflash I tried to root my phone again by the KingRoot app. It went fine upto 24% when I thought of disconnecting the router which it was connected to. The app showed me that a file could not be downloaded and then as it happens (on this device particularly during rooting, the phone shut down). Usually in such cases I remove the battery and reinsert it and boot the phone to continue with the root procedure but this time it did not happen. I tried twice but failed. It was after that I removed the battery for about 30s that it booted up again. After the boot the battery indicator in status bar was working in a strange manner. It first showed 50% then the next instant dropped to 2%, and remained there for about 1 hour. Then after I plugged the charger it again jumped back to 50%. In spite of this I charged the phone for rest of the evening. When I again started using it some minutes back, it started behaving strangely again. Initially the charge was 88% then it jumped down to 50% then to 69% and so on. Here are some statistical screen shots taken from 3C Toolbox.

enter image description here enter image description here

This one from the battery section of settings app. See the ups and downs at the end. enter image description here

And another problem, I see this annoying notification even when my battery is at normal temperature. enter image description here

My device is 2 years old so there are no issues with the battery itself I think it is the OS files that are causing the disturbance. I think this would be a silly question (as it is not possible) Did this happen due to the kingRoot app? What may be the cause, please help me out.

EDIT

The battery files of the OS, I think these (the current_now and the temp_cool ones) probably have been corrupted in some way. Can they be replaced with files downloaded from the internet(if any). Please help

enter image description here

  • It seems (though I will not confirm as I'm no developer) that the failure of the root process has resulted in the corruption of files in the OS partition, due to which these are happening. The battery history screenshot looks dangerous with so many spikes, with such a great slope, which indicates that there is a problem as no battery can be charged so fast. Unfortunately, I've got no solution for this, but will keep looking upon this question to see if someone has a solution. – Wrichik Basu Nov 9 '17 at 7:33
  • @WrichikBasu But my question is how. The root process installs an su binary file in /system/bin folder but how can it affect /sys/class/devices/power_supply/battery folder. They are way apart. – jyoti proy Nov 9 '17 at 8:37
  • As I said, I'm not a developer, so whatever I said was a "may be". – Wrichik Basu Nov 9 '17 at 8:38
  • @WrichikBasu I respect your argument, and I too thought that, but I'm just confused. How can this happen. I've rooted this device two times before, such things never happened. I think I have to reflash the rom again. – jyoti proy Nov 9 '17 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.