My Yuphoria 5010 got into bootloop after installing a custom ROM. My friend tried to fix it but deleted the recovery following a tutorial.

Now the device is stuck at the boot logo.

Is it possible to hard format the device to the default ROM anyhow?

Update: This is not a normal bootloop. The problem here is the ROM could not be rewritten. Any writing attempts are being failed. The device was infected with a malicious adware which couldn't be deleted and that's the reason I tried to format the device. Is there any way around if the writing modules fail?

  • If you flashed a custom ROM, that overwrote (replaced) your "default ROM". So getting it back would mean to flash it. Same goes for the recovery, it can be flashed (provided you've got the image). Usually that's done via fastboot, but you might need to check if your device does that as well (not all devices support fastboot).
    – Izzy
    Nov 12 '17 at 10:34
  • Is fastboot working?
    – Gokul NC
    Nov 12 '17 at 12:48
  • @GokulNC fastboot is working but the problem is ROM is not being flashed as all writing attempts are failing Nov 13 '17 at 10:51
  • To get more specific help, you'll need to explain more precisely than "failing". What commands did you run, and what results did you get? Give the exact text of any error messages.
    – Dan Hulme
    Nov 13 '17 at 16:36

Flashing a stock firmware should fix this.

  • Download and extract Yu Yuphoria YU5010 stock firmware on your computer
  • After extracting, you should get the Firmware File, Flash Tool and How-to Flash Guide.
  • Install the USB Driver on your Computer
  • Follow the How-to Flash Guide to Flash the Firmware .

Follow the steps carefully and your problem should be fixed.

  • Nothing could be written Nov 13 '17 at 10:56
  • What do you mean?
    – esQmo_
    Nov 13 '17 at 19:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.