1

From one day to the other, my LG magna phone suddenly started stuttering a lot. Several problems are occurring, and all of them had their onset at same time:

  1. Many apps stopped working, and don't even start or are stuck in white-screens when I start them: Google play store, Google Inbox, Google Calendar, Google Maps, Facebook Lite, 9Gag, Instagram.
  2. Lag on input: when I type, my key touches have some delay in being recognized. For instance, type "Pizza restaurants" on internet, and the word "Pizza" types normally, but then image freezes, and suddenly the entire word "restaurants" is recognized.
  3. Apps misbehaving: some other apps do not work properly, which is the case of the Weather app (also by google?) that never lets me change location - "Unable to show locations".
  4. Phone stuttering: upon watching youtube or other videos, every 10-20 seconds there are like 2-3 seconds frozen video, followed by a "rushed" catch up of those frozen frames.
  5. Phone became quite slow suddenly.
  6. Google Play Store doesn't open.

I have not installed anything. I have already tried:

  1. Rebooting many times;
  2. Cleaning cache/stored data of Google Play store, Google services, etc. Note that now I cannot clean stored data of Google Play store as the screen becomes white when I press "Manage space".
  3. Cleaning cache of phone by going to Device storage.
  4. Airplane mode.

The only thing left to do is factory reset, but maybe you can give me any suggestions before I resort to it?

Phone became a brick...

Thanks in advance

  • Yes, I have tried the two possible steps for my phone (clearing cache, deleting apps). Right now, I have barely any apps installed. – Sosi Nov 15 '17 at 9:46
  • You could try taking a look at the logs while performing one of those "broken actions". That might (hopefully) give a clue on what might be wrong. – Izzy Nov 15 '17 at 9:49
  • @Izzy, I ended up doing a factory reset since it would take me more time to learn to use the logs effectively, especially given how slow it was. The factory reset solved all problems - I was really afraid it was a hardware problem. Thanks for all your tips anyway! – Sosi Nov 16 '17 at 9:37
  • 1
    There are times when even a factory reset doesn't seem to solve it – and one has to find the exact culprit to get rid of it (a specific app or even a bug in the ROM itself, or problems with the file system on the external SD card – all things I've already seen). Didn't say you must evaluate those logs all yourself: if you'd upload them to e.g. a pastebin, others might have a look as well and be able to help out better. So: Glad you solved it for now – and just keep the rest in mind, might come in useful another time :) – Izzy Nov 16 '17 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.