3

I recently downloaded system images for API Level 26 (Android 8.0), on my SDK emulator but unfortunately I can't boot the virtual device all the way to home screen.

I'm stuck on the following screens:

enter i

One which request a description password;

enter image description here

(and the other showing that description want successful (which is confusing me)

I have tried different things to no avail:

  • tried wiping user data whilst starting the AVD
  • tried deleting/swapping user data.img
  • tried starting the AVD from command line
  • swtching google_apis_playstore image with google_apis image(which never boots)

And all these instances still I can't start successfully the virtual device.

Is there something I'm missing or is there a workaround to bypass the screens?

  • Hi, please let us know if you were able to solve this issue. I am also facing same error. – salah9 Apr 25 '18 at 15:16
  • 1
    @salah9 I am glad to inform you that I have found a working solution to run Oreo on standalone sdk :) – xavier_fakerat Jul 3 '18 at 16:29
1

I managed to get the Android 8.1 images to run on the emulator. I figured out the main issue was to do with emulator itself which was rather outdated.

From the looks of things it seems the emulator (originally distributed as part of the Android SDK Tools) is no longer updated since version 25.2.3

The solution was to manually update the emulator, to make it compatible to run API level26. The emulator tools (for windows) can be found here: https://dl.google.com/android/repository/emulator-windows-4266726.zip or linux

Instructions

  • Download the latest emulator from the above link or here
  • When done, decompress the downloaded emulator.zip file and extract the emulator package to %USERPROFILE%\Android\android-sdk\tools or relevant path (yes you have to merge it into that folder, since the emulator doesn't have all libraries and files)
  • After this your emulator will be updated (to 26.1.4 in my case)
  • Now prepare your AVD (API level 26 or 27) as usual and should be up and running.

Although, the standalone SDK Manager and AVD Manager (GUIs) have been deprecated in favour of command line sdkmanager tool found in android_sdk/tools/bin/, you can still update the emulator using the method mentioned here: https://developer.android.com/studio/command-line/sdkmanager.

enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.