My Samsung Galaxy GT-i5800 has had the wrong pass entered too many times, and now it's not opening up. So how do I do a factory reset on it, since all the workarounds I've tried (phoning it, mashing keys, putting 'null' as the password') haven't worked?

  • 1
    A few questions: You don't get a button pop up in the bottom-right allowing you to enter your Google password to unlock the phone? Or a timeout before you can try again? Do you mean the i5800 rather than 15800? Have you rebooted the device? – Matthew Read Jan 23 '12 at 22:48
  • I'm pretty sure it's the 15800. When I enter my Google account, it comes up with an error, despite me entering it correctly. It's permanently locked. I have rebooted it. – Drop Jan 24 '12 at 7:56
  • the GT-15800 is the galaxy apollo; GT-i5800 is the galaxy 3 – Ryan Conrad Jan 25 '12 at 17:33
  • 1
    @RyanConrad According to Samsung the Galaxy Apollo and some Galaxy Minis are i5800 and the Galaxy 3 is the i5801, all three just variants of the same thing. 15800 is just a misreading, that's why I always lowercase the i. – Matthew Read Jan 26 '12 at 0:25

Reboot into recovery, where you can select the option to factory reset (scroll up/down with the volume keys, use power to select).

Two ways to get into recovery:

  1. Install the Android SDK on your computer and run adb reboot recovery
  2. Power off the phone, hold down both volume buttons and (while holding) click the power button. Release the volume buttons when recovery appears.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.