I installed an app today on a six month old ZTE Axon 7. I have installed many apps on this device before and never had a problem, and I have plenty of storage left on my phone. This app downloaded and installed normally, including a playstore alert that installation was successful, but it never appeared on my home screen. I went to look for it in my list of all apps, but it wasn't there either. When I go back into Play Store and view the app's detail page, it only shows one button: uninstall. All other apps also show an "open" button.

I did install this from the play store and not a browser. I searched for it an installed from Play Store and did not follow a link to the details page. The app works on my old Sony Xperia Ion, and Play Store lists it as "compatible with all your devices". I tried uninstalling the app and then reinstalling the app. I also tried restarting the phone.

I have searched Google and found many reports of other users having a similar problem, but the only solution reported to work is to download it from the play store (as apparently these users installed from a web link). Just in case, I enabled the "allow installation of apps from unknown sources" and then reinstalled the app, but still got the same result.

What could cause this and how can it be fixed?

If it's relevant, the app is: https://play.google.com/store/apps/details?id=com.nightscapecreations.anim3free&hl=en

  • It uninstalls normally like any functional app. And the install takes just as much time as expected to download the apk and then install it. What side effects might clearing the playstore data have?
    – Nicholas
    Commented Nov 22, 2017 at 19:50

1 Answer 1


Here are the instructions from the page that you linked:

INSTRUCTIONS Setting a live wallpaper works differently from device to device, and on different versions of Android. In most cases you can set a live wallpaper the same way you set a static wallpaper. Try these methods, and if they don't work feel free to contact us:

1) Tap an open area of your desktop, look for an edit icon, and choose "Wallpaper" and then "Live Wallpaper" from the list that appears 2) Go into "Settings" - "Display" - "Wallpaper" - "Live Wallpaper" 3) Go into "Settings" - "Personalization" - "Wallpaper" - "Live Wallpaper

Try going to set the wallpaper the way you normally would and see if WPS Video Live Wallpapers is there waiting for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .