I have a wifi connection setup at my home. Other devices like my ubuntu laptop and macbook, when connected to wifi are able to access internet. Even my dad's blackberry is able to load websites when connected to internet via our home wifi. My HTC desire is able to connect to wifi, shows a good signal, but is not able to connect to internet. My friend's android phone have same issue. I can access a website running on my ubuntu (apache) using my browser and ip assigned to my ubuntu box, but I cannot open google or any other website. Even marketplace show connection error.

Can someone help me out with this.

2 Answers 2


Did you try setting manually the IP+DNS, instead of relying on DHCP, as it does by default?

Wireless and Networks -> Wi-Fi settings -> [menu] -> Advanced -> Use static IP

  • I had a little trouble with this at first. 2 things: First, Wifi Static is a handy free app if you use more than one wireless network. Second, make sure there isn't an IP conflict on the router by pinging the IP you intend to use before you connect to make sure it isn't already taken.
    – Hemlock
    Commented Apr 27, 2012 at 14:16

Are you using IPv6 on your router? There was a question here just the other day, that identified an issue with android resolving an IPv4 address when it has an IPv6 address.

Here is the post I am referring to. If you can, set your router to use IPv4 (for now).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .